Excel Teil Rechts Finden Suchen?

3 Antworten

Du willst doch immer alles nach dem ersten Leerzeichen haben... also eigentlich ganz einfach:

=RECHTS(A1;LÄNGE(A1)-FINDEN(" ";A1;1))

Nur was ist, wenn jemand zwei Vornamen hat? Wie differenzierst du zwischen Nachnamen und Vornamen?

Den Gedanken habe ich mir auch gemacht, habe aber beim durchschauen der Liste festgestellt, das es niemanden mit 2 Vornamen gibt.

Es handelt sich hierbei um eine Liste die von einer Mietergesellschaft erstellt und nachgeführt wird, wir haben dort einen Wartungsvertrag und bekommen 1x im Jahr die Liste zugeschickt um entsprechend zu terminieren und anzuschreiben, ich nenne die Liste einfach jedes Jahr gleich und somit werden die Namen automatisch bezogen, da ich ansonsten 580 Namen manuell eintragen muss.

Laut Rücksprache mit der Gesellschaft wird immer nur der Hauptvorname eingetragen.

0
@Gipfelstuermer

Vielen Dank, was aber noch störend ist, wenn ich nur 1 Wort habe (ja es gibt Ausländer ohne Vornamen), dann bekomme ich #WERT, ein leeres Feld (noch nicht vermietet Wohnungen kann ich ja mit einem simplen WENN abfangen. Aber wie fange ich ab ob es nur 1 Wort hat?


0
@Gipfelstuermer

Du kannst auf Fehler prüfen...

=WENNFEHLER(RECHTS(A1;LÄNGE(A1)-FINDEN(" ";A1;1));A1)
0

Du willst alles außer dem ersten Wort haben?

=TEIL(A1;FINDEN(" ";A1)+1;9^9)

Was bewirkt das "9^9" in der Formel?

0
@ShitzOvran

Achso... einfach nur eine unverschämt große zahl, damit sichergestellt ist, dass bis zum ende geschaut wird?! Weil man davon ausgeht, dass der text nicht länger als 387420489 Zeichen sein wird ;)

1
@ShitzOvran

Ja, genau. Früher habe ich 1024 geschrieben. 9^9 ist größer und kürzer.

Das letzte Argument ist leider nicht optional.

0
@Suboptimierer

Und da die Zeichenanzahl in einer Zelle auf maximal 32767 Zeichen beschränkt ist, erwischt man definitiv immer alle - clever

0
@ShitzOvran

Dann würde 6^6 schon reichen. 9^9 hat den Nachteil, dass Excel das erst berechnen muss.
Ideal, aber umständlich wäre es, die genaue Anzahl an Zeichen mit LÄNGE und FINDEN zu bestimmen.

Oubiy hat mich einmal darauf hin gewiesen, dass bei manchen Formeln (ich weiß nicht mehr welchen), das 9^9 weggelassen werden kann. Er verwendete das sonst auch.

0
@Suboptimierer

Vielen Dank, für die schnelle Antwort, ob nun 6^6 oder 9^9 ist in meinem Falle total egal, mir hätte eine 100 gereicht, was aber noch störend ist, wenn ich nur 1 Wort habe (ja es gibt Ausländer ohne Vornamen), dann bekomme ich #WERT, ein leeres Feld (noch nicht vermietet Wohnungen kann ich ja mit einem simplen WENN abfangen. Aber wie fange ich ab ob es nur 1 Wort hat?

0

Was möchtest Du wissen?