Excel Tabelle Funktion - Hilfe?

...komplette Frage anzeigen

4 Antworten

=10*(SUMMENPRODUKT((B:B)*(A:A="X")-(A:A="Y")))

(ungetestet)

Antwort bewerten Vielen Dank für Deine Bewertung
Funfroc 19.10.2016, 09:49

so gehts auch... getestet :-)

1
Suboptimierer 19.10.2016, 09:51
@Funfroc

Habs versucht, noch ein bisschen zu optimieren. Geht hoffentlich immer noch.

0
Asker0932 19.10.2016, 09:49

Vielen Dank. So in der Art müsste es eigentlich hinhauen, leider #Wert

0
Funfroc 19.10.2016, 09:58
@Asker0932

jetzt komme ich gar nicht mehr mit. Das ist also richtig... meins aber nicht?

Die Funktionen machen beide das gleiche, nur mit unterschliedlichen Ansätzen.

1
Asker0932 19.10.2016, 10:06
@Funfroc

Hey, tut mir Leid, deins haut auch hin, siehe Kommentar bei deiner Antwort. Auch dir: Herzlichen Dank

0
=SUMMENPRODUKT((A1:A100="X")*(B1:B100)*10)-(ZÄHLENWENN(A1:A100;"Y")*10)

oder

=SUMMENPRODUKT((A1:A100="X")*(B1:B100)*10)-SUMMENPRODUKT((A1:A100="Y")*10)

Die anderen Ansätze gehen mit einer Hilfsspalte, also wenn du

=WENN(A1="x";B1*10;-10)

in eine neue Spalte und bis zum Ende der Liste kopieren. Darüber die Summe. Mit Summenprodukt geht es mit einer Zelle.

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo,

soweit ich dich verstehe... so:

=(SUMMEWENN(A:A;"X";B:B)*10)-(ZÄHLENWENN(A:A;"Y")*10)

LG, Chris

Antwort bewerten Vielen Dank für Deine Bewertung
Asker0932 19.10.2016, 09:52

Hallo, vielen Dank, die Formel funktioniert zwar. Aber du hast mich etwas missverstanden. Bei jedem Y soll einfach -10 subtrahiert werden, nicht alle Y's zusammen mit mal zehn abziehen. Kannst du das vielleicht noch anpassen? Vielen Dank schonmal!!

0
Funfroc 19.10.2016, 09:56
@Asker0932

Sorry, mit der Fomulierung komme ich jetzt nicht mit.

Bei jedem Y soll -10 gerechnet werden. Wenn ich in Zeile A2, A4 und A6 ein Y stehen habe soll also für A2, A4, und A6 jeweils -10 gerechnet werden. Das sind ergo -30.

Genau das macht meine Funktion.

Oder willst du das Ergebnis immer nur bis zu der jeweiligen Zeile haben?

Dann so:

=(SUMMEWENN(A$1:A1;"X";B$1:B1)*10)-(ZÄHLENWENN(A$1:A1;"Y")*10)
0
Suboptimierer 19.10.2016, 09:56
@Asker0932
Bei jedem Y soll einfach -10 subtrahiert werden, nicht alle Y's zusammen mit mal zehn abziehen.

Wo ist der Unterschied?

n * (-10) = ∑ -10, i=1..n 

1
Asker0932 19.10.2016, 10:05
@Funfroc

Hallo, tut mir Leid, war ein Denkfehler meinerseits, weil ich es direkt an einer komplexen Tabelle versucht habe. Funktioniert aber: also vielen vielen Dank!!

0
Funfroc 19.10.2016, 10:09
@Asker0932

ok, Denkfehler kommen vor... bei jedem.

Als Tipp:

Lege dir für sowas immer schnell eine separate Testtabelle mit wenigen Werten an, wo du das gewünschte Ergebnis schnell per Hand ausrechnen kannst.

Dann siehst du, ob die Formel das errechnete Ergebnis bringt. Kurz Querprüfen, ob bei Änderungen das Ergebnis immer noch stimmt.

Wenn alles passt kann man die Formel für die "richtige" Tabelle nehmen.

LG, Chris

1

=WENN(A1="x";B1*10;-10)

Antwort bewerten Vielen Dank für Deine Bewertung
Asker0932 19.10.2016, 09:43

Danke, aber soll ja nicht nur für A1 und B1 sein sondern für alle A's und B's

0
LeroyJenkins87 19.10.2016, 09:44
@Asker0932

Das kannst du dann einfach runterziehen und dann ganz unten

=SUMME(C1:C??)

 

1

Was möchtest Du wissen?