Excel Tabelle - von 1300 Zeilen 300 automatisch rausfiltern.

...komplette Frage anzeigen

3 Antworten

Beide Dokumente geöffnet halten ist wichtig, weil sonst der externe Bezug (aus der Sicht des einen Dokumentes bzgl des anderen) nicht funktioniert.

Dann würd ich je nach Zielsetzung (nur kennzeichnen? Auflisten? ...) über Bedingte Formatierung oder Summenprodukt oder INDEX(... VERGLEICH(..)) gehen und die Spalten vergleichen. Letztlich ist es Excel "egal" wo die Daten stehen / die Bezüge hinzeigen.

So gehen externe Bezüge:

http://office.microsoft.com/de-de/excel-help/erstellen-eines-externen-bezugs-verknupfung-zu-einem-zellbereich-in-einer-anderen-arbeitsmappe-HP010342364.aspx

Hier die Lösung (mit XL2007):

2 Dateien: Zählenwenn1.xlsx (entspricht ABC) und
Vorhanden.xlsx (entspricht XYZ)

In Spalte E: =ZÄHLENWENN([Vorhanden.xlsx]Tabelle1!$A$3:$A$13;A3)
und runterziehen bis Tabellende.

Jetzt haben alle in "Vorhanden.xlsx" stehenden Artikel eine 1 in Spalte E.
Nun noch den Autofilter einschalten, "1" anzeigen lassen,
>>>FERTIG

Kostenlose Zugabe:
Die Summe der gefilterten Werte (also die "sichtbaren") wird in D1 angezeigt mit:
=TEILERGEBNIS(9;D3:D13)

Wie Ortogonn schon richtig sagte, es müssen beide Dateien geöffnet sein.

Ist Dir damit geholfen ?

Gruß aus Berlin

Zählenwenn - (Computer, PC, Windows)

Hallo PrinceVan,

den Tipp von Ortogonn habe ich natürlich gleich ausprobiert, weil ich annahm, dass es nicht geht, in der bedingten Formatierung Bezug auf andere Tabellen zu nehmen.

Und tatsächlich, Excel meckert, wenn man in der bed. Formatierung die Tabellen wechselt (siehe screenshot).

Gruß Distel

Bedingte Formatierung mit Bezug in andere Tabellen geht nicht - (Computer, PC, Windows)

Was möchtest Du wissen?