EXCEL? SVERWEIS? Wie soll das funktionieren?

...komplette Frage anzeigen Excel Auftrag - (Computer, Mathematik, Excel)

5 Antworten

Die richtige Formel wurde ja genannt...Du brauchst allerdings mehr als einen SVERWEIS

Um Dir nicht die Chance zu nehmen, die Formel tatsächlich zu verstehen, zunächst mal eine grundlegende Erklärung anschauen (gibt auch diverse andere Seiten zum lesen oder Videos, wem das mehr liegt):

https://support.office.com/de-de/article/SVERWEIS-Funktion-0bbc8083-26fe-4963-8ab8-93a18ad188a1

Dann für den ersten Fahrer in G12 die Ermittlung des Kraftstoffs:

=SVERWEIS(D12;H$4:I$9;2;FALSCH)

Das FALSCH hier steht für "ungefähre Übereinstimmung = NEIN" sprich es soll nach einem genauen Treffer gesucht werden.

Die $ Zeichen dienen dazu, dass der Zellbezug nicht verändert wird, wenn Du die Formel für die anderen Fahrer kopierst (die Zwischentabelle mit Fahrzeug, Kraftstoff und Verbrauch soll ja nicht mitrutschen)

Für Deine Berechnung musst Du du in eine Gesamtformel neben dem genannten SVERWEIS zur Ermittlung Kraftstoffart noch SVERWEIS für Verbrauch und SVERWEIS für Preis verbinden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von CheonSongyi
15.04.2016, 12:49

Danke, es kommt aber irgendwie nicht wirklich etwas heraus...Zum Verstehen bleibt mir keine Zeit mehr gerade. Wenn ich das geschafft hätte, hätte ich jetzt einen 1er xD

1

zunächst muss aus der Automarke der Treibstofftyp ermittelt werden.

also ein Sverweis = suche Automarke in Fahrzeugtabelle und geben den Wert in der Spalte Treibstoff zurück.

Mit diesem Wert wird dann der Preis des Treibstoffs ermittelt.

Treibstoffpreis x Treibstoffmenge sind dann die Kosten. Die verbrauchte Menge ermittelt sich wiederrum aus der Automarke und der Km Zahl

Antwort bewerten Vielen Dank für Deine Bewertung

Da hat sich aber jemand eine komplizierte Formel ausgedacht. Du sollst also anhand aller Daten nur in den Zellen G12 bis G21 die Spritkosten herausfinden und dabei noch ne SVERWEIS-Formel benutzen?

Lässt sich so frei aus dem Kopf nur schwer sagen, das müsst ich nachstellen.

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo :)
Für den Treibstoff brauchst du diese Formel:

=SVERWEIS(D12;H4:J9;2;0)

Für den Verbrauch dann diese hier:

=SVERWEIS(D12;H4:J9;3;0)

Für den Spritpreis dann diese hier:

=SVERWEIS(G12;C4:D7;2;0)

Die erste Formel tippst du in "G12" ein, die Zweite dann in "H12" die dritte in "I12"

Dann hast du die Übersicht über Verbrauch, Treibstoff und den Spritpreis.


Grüße,


Philip


P.s.

In einer Formel wäre es dann so:

=SVERWEIS(D12;H4:J9;3;0)*F12*SVERWEIS(SVERWEIS(D12;H4;J9;2;0);C4:D7;2;0)/100


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von CheonSongyi
15.04.2016, 12:52

Danke, funktioniert bei mir aber nicht :(

1
=(SVERWEIS(B11;F2:H7;3)*SVERWEIS(SVERWEIS(B11;F2:G7;2);A1:B4;2)*C11)/100

A1 bis B4 = Preistabelle
F2 bis H7 = Fahrzeugtabelle
B11 bis C20 = Tabelle mit Daten (bei mir nur Hersteller und KMstand)

Is natürlich nur ein Beispiel, geht vllt auch etwas eleganter oder einfacherer. Wenn du die Formel runterziehen willst, natürlich entsprechend mit $ sperren.

Formel - (Computer, Mathematik, Excel)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von CheonSongyi
15.04.2016, 12:45

Wie...Sperren? xD

1

Was möchtest Du wissen?