Excel SVERWEIS Problem SQL Abfrage

2 Antworten

steht in der zelle A212 ein wert der in der datenbank nicht vorkommt?

ohne die tabellen real zu kennen ist da schwierig zu helfen.

JA der Wert kommt in A212 vor (Tabelle Aufstellung) und in der Tabelle1 (Daten als der SQL Datenbank).

Geht generell ein SVERWEIS auf SQL Daten??? Ich habe die Vermutung das es die Formatierung der Zellen.

0
@goalkeeper001

mit SQL-daten meinst du wohl die importierten. problem könnte sein, dass die importierten nummern strings sind und die vergleichswerte numerisch (oder umgekehrt).

wie gesagt: ohne die tabellen kann man nur raten

0
@goalkeeper001

Diese Vermutung habe ich auch.

Kopier mal zur Probe eine beliebige Nummer aus Tabelle1!A und füge sie in A212 ein. Geht es dann?

Ich hatte neulich einen ähnlichen Fall (Daten von einer Webseite kopiert), wo die Werte auch nicht mit manueller Eingabe gefunden wurde, ein kopierter Wert aber schon. Manchmal gibt es z.B. versteckte Leer- oder Steuerzeichen.

0
@DeeDee07

Ja daran liegt es!

In der Tabelle Aufstellung sind die Zahlen als Standard und in der Tabelle1(SQL Query) wohl nicht. schreibe ich hier WERT(A1) in die Spalte Z oder so und lasse die Zelle prüfen geht es. Nur kann das ja nicht das Ziel sein.

Wie stell ich den SVERWEIS um damit er direkt den SQL Datenimport nimmt.

0
@goalkeeper001

Keine elegante Lösung, aber ein Workaround:

Schreibe auf ein neues Tabellenblatt in A1
=WERT(Tabelle1!A1)
und vervollständige diese Formel soweit nach unten und rechts wie nötig.

Benutz dann diese neue Tabelle in deiner SVERWEIS-Suchmatrix.

0
@DeeDee07

geht nicht das sind so schon mehrer Datenblätter wenn ich jetzt für jedes ein neues Datenblatt erstelle werden das zuviele Abfragen. Die SQL Daten werden ja auch immer aktualisiert und so wäre die Formel nicht zu gebrauchen.

Der SVERWEIS muß das direkt lösen :(

0
@DeeDee07

lt. beschreibung sollte wert nicht funktionieren, da in den formeln entsprechende anpassung automatisch durchgeführt werden.

soweit der fragesteller nicht bereit ist, die entsprechenden tabellen (2) zur verfügung zu stellen, klinke ich mich hiermit aus.

0

Hilft es, den SVerweis abzuändern?

SVERWEIS(Text(A212;"@");Tabelle1!A:C;3;FALSCH)

Außerdem kannst du dir die Funktion noch übersichtlicher machen, indem du

WennFehler() benutzt statt Wenn(IstFehler()).

Also so:

=GROSS2(WENNFEHLER(SVERWEIS(Text(A212;"@");Tabelle1!A:C;3;FALSCH);""))

0

Excel Sverweis #NV

Hallo,

folgende Situation;

Ich habe 2 Excel Tabellen in 2 Registerblätter einer Exceldatei. Mit dem Sverweis möchte ich nach der Artikelnummer in der zweiten Tabelle suchen lassen und mir den aktuellen Bestand in der vorgesehenen Spalte der ersten Tabelle anzeigen lassen. Im Ausgabefeld erschein jedoch immer nur #NV.

Mein Sverweis lautet: =SVERWEIS(B126;Tabelle2!A2:M660;13;FALSCH)

Kurze Übersicht : In Spalte B (Tabelle1) habe ich die Artikelnummer nach der in der 2. Tabelle gesucht werden soll. Die Matrix ist die 2. Tabelle. In Spalte 13 (Tabelle2) findet man den Bestand den ich mir in der ersten Tabelle anzeigen lassen möchte.

Hoffe, dass jemand den Fehler entdeckt und mir weiter helfen kann.

Lieben Gruß

...zur Frage

Formel mit SVERWEIS?

So in einer Excel Tabelle gibt es eine Spalte mit Datumsangaben; 2. Spalte Name und 3. Spalte Preis.

Mithilfe von SVERWEIS möchte ich 2 Datumsangaben raussuchen zB 22.08.17 und 28.08.17 und nun soll er sämtliche Preise vom 22.08.17 bis zum 28.08.17, die bei diesen Daten hinterlegt sind, zusammenrechnen.

Gibt es dafür überhaupt eine Formel?

...zur Frage

WENN-DANN-SONST leere Zeile entfernen?

Wenn der Wert in Tabelle 1 der Spalte D ja ist, dann soll er den Wert von Tabelle 1 Spalte B übertagen sonst soll es leer bleiben.

=WENN(Tabelle 1!D:D="ja";Tabelle1!B:B;"")

Jetzt habe ich dass Problem, dass ich leere Zeilen in meiner Tabelle habe, wie kann ich diese entfernen bzw. was muss ich bei der Formel unter SONST eintragen?

...zur Frage

Tabelle SQL Auflistung nach größter Zahl?

Hey, ich habe hier eine Bestell Tabelle, ich möchte in einer Reihenfolge auflisten welche Produkte am häufigsten bestellt worden sind. Geht das in einer weiteren Tabelle oder mache ich das per Abfrage?

...zur Frage

Excel Hilfe - In Spalte nach Wort/Passage suchen und ganze Zeile ausgeben?

Ich habe eine große Tabelle mit nur 1 Spalte.

Nun gibt es 2 Arten von Daten in der Tabelle.

  1. "Vorname Name Vorname Name vorname.Name@abc.de vorname.name 27E8CE29-EA16-9FDF-4125-67DF0030C902 CN=Vorname Name,OU=HGS,O=ABC,C=DE active false false "

2. Vorname Name Vorname Name vorname.Name@extext.de Vorname.name@extext.de ADC4A595-F646-43C8-C125-7E8B0049A8AF CN=Vorname.Name.ext.de,O=ConnectExt active true "-"

Der gesammte Text steht jeweils in nur einer Zelle

Der Unterschied liegt bei "O=ABC" bzw. "O=ext"

Ich soll nun alle Zeilen die "ABC" beinhalten in eine 2. Tabelle ausgeben.

Ist dies Möglich? Wenn ja wie? pls Help :)

...zur Frage

Was speichert man in Datenbanken ab?

Was wird da abgespeichert genau? .z.B. habe ich eine Website programmiert die halt nicht so groß ist aber ich möchte mit Datenbanken arbeiten was und wie (programm) speicher ich das ab?

...zur Frage

Was möchtest Du wissen?