Excel SVerweis mehrere Einträge in eine Zelle?

3 Antworten

Ich kann bei dem Beispiel noch nicht erkennen, wo der Sverweis ins Spiel kommt, aber das Verketten von Inhalten ist mit & schon richtig, allerdings ohne das +

Also =A1 & " " & C1 & " " & B1

(ich hab unterstellt, dass da noch Leerzeichen dazwischen sollen). Du kannst auch das Ergebnis von Formeln auf die Weise verketten, wenn also Anrede, Vorname, Name über SVERWEIS ermittelt werden, dann ist es halt
=sverweis(....) & " " & sverweis(....) etc.

Was Du Dir auch anschauen könntest wäre Serienbrief in Word - Excel als Datenbasis aber den eigentlichen Brief in Word, was hinsichtlich Texte formatieren natürlich wesentlich komfortabler ist.

Super, es hat funktioniert. Gibt es eine Möglichkeit einen Leerzeichen zwischen B1 und C1 einzufügen. Jetzt steht nämlich "VornameNachname" im Briefkopf.

0

kannst du vlt versuchen genauer zu erklären wie du das meinst ich blick nicht ganz durch :D aber in excel war ich eig ganz gut :D

Um meine Frage etwas zu konkretisieren, lade ich mal Screenshots hoch. Ich würde gerne in C16 bei Rechnung sowohl den Vor- als auch den Nachnamen aus den Spalten D und E einfügen.
Derzeit kann ich ja nur den Vornamen bei C16 und den Nachnamen bei D16 einfügen.

=WENN(F21="";"";SVERWEIS(F21;Kunden;4;FALSCH))

So ist mein SVerweis stuktusiert. Ich habe bereits folgende Varianten versucht:

=WENN(F21="";"";SVERWEIS(F21;Kunden;4&5;FALSCH))

=WENN(F21="";"";SVERWEIS(F21;Kunden;4+5;FALSCH))

=WENN(F21="";"";SVERWEIS(F21;Kunden;4;5;FALSCH))

BlattKunden - (VBA, Excel SVerweis) BlattRechnung - (VBA, Excel SVerweis)

mit sverweis kannst Du leider nur einen Wert übernehmen. Du kannst aber mehrere sverweis-Ergebnisse verketten und mit &" "& auch noch ein Leerzeichen dazwischen

=WENN(F21="";"";SVERWEIS(F21;Kunden;4;FALSCH)&" "&SVERWEIS(F21;Kunden;5;FALSCH))
0

Excel Zellvergleich: VBA oder bedingte Formatierung?

Ich habe eine Excel Tabelle mit 2 Spalten und einigen Zeilen. Nun möchte ich es schaffen, dass eine Zelle nach der anderen (For Schleife?) aus Spalte A mit allen Zellen aus Spalte B verglichen wird. WENN der Inhalt der Zelle aus Spalte A IN einer Zelle in Spalte B vorhanden ist, DANN färbe die Zelle NUR in Spalte B ein.

WIe mache ich das am geschicktesten? Geht es mit bedinger Formatierung oder VBA besser?

...zur Frage

Bilder automatisch durch Nummer in Excel zuordnen?

Hallo, ich habe folgendes Problem: Ich habe 2 Tabellen. In einer sind lediglich Artikelnummer und ein dazugehöriges Bild, in der Zelle daneben. Die andere Tabelle die Artikelnummern und dazugehörige Information wie Name etc.. Jetzt möchte ich gerne, dass die Bilder anhand der Artikelnummern, dem richtigen Artikel zugewiesen werden. Kann man das irgendwie umsetzen? Sind enorm viele und würde mir einige Zeit ersparen. Danke.

...zur Frage

Excel 2 Formeln verbinden?

Hallo Leute,

ich möchte in Excel in einer Zelle einen Sverweis und eine WENN-Funktion einbauen. Wie kann ich diese miteinander verknüpfen? Wenn(Sverweis...) fällt weg. Kann man die beiden Formeln separat durch ein + verbinden? Sprich erst den Sverweis ud dann + WENN?

lg

...zur Frage

Excel VBA. Wie kann ich eine Zelle in ein anderes Tabellenblatt in eine bestimmte Spalte einfügen?

Wie kann ich zum Beispiel aus Tabellenblatt Zelle A11 Werte in Tabellenblatt 2 kopieren und dabei Spaltte "B" hineinkopieren? Außerdem soll Excel immer in die nächste frei Zeile die Werte hineinkopieren.

...zur Frage

Exif-Daten durch Excel(VBA)?

Hallo, ich habe eine Datenbank mit Fotos in Excel erstellt. Jetzt möchte ich aber, dass das Datum das Datum der Aufnahme ist, also das Datum, das in den Exif-Daten der Bilder angegeben ist. Ich habe die Funktion .DateTimeOriginal gefunden, aber habe gelesen, dass diese Funktion nicht in VBA arbeitet, da sie aus einer anderen Sprache, VB .NET, ist und in Visual Basic Express angewendet werden kann. Gibt es andere Möglichkeiten die Exif-Daten rauszuleiten durch VBA ?

...zur Frage

Excel VBA Button erstellen mit dem ich automatisch in eine Zelle springen kann?

Hallo,

ich habe ein sehr langes Formular erstellt und dieses mit VBA programmiert.

Gibt es die Möglichkeit, dass ich eine CommandButton (andere Lösungen wären auch okay) erstellen kann, mit dem ich dann automatisch ein eine bestimmte Zelle springe?

Vielen Dank für Antworten :)

...zur Frage

Was möchtest Du wissen?