Excel/ Sverweis / 2 Werte?

...komplette Frage anzeigen

2 Antworten

mit dem SVergleich gehts m.W. nicht, mit

index(Bestellspalte;Summenprodukt(KKleinste(Zellenvergleich mit Name)*Zeile;2))

müsste das schon gehen, aber ich habe leider keine Vorstellung bekommen, wie Dein Blatt zum auslesen aussieht. Das ist genauso wichtig wie die Beschreibung des Zielblatts, von dem ich wahrscheinlich ein zutreffendes Bild entwickeln konnte.

Spezifiziere, wie die Tabelle heißt, wo dort der Name steht und wo das Bestelldatum: Name ebenfalls in A, Bestelldatum in B? dann: (in Stamm!C2)

{=Index(Bestellungen!B:B;Kgrößte((A:A=Stamm!A:A)*Zeile(A:A);1)}

und in Stamm!B2:

{=Wennfehler(Index(Bestellungen!B:B;Kgrößte((A:A=Stamm!A:A)*Zeile(A:A);2);"- -")}

Da Kgrösste einfacher zu handhaben ist wie KKleinste, taucht die erste Bestellung in C2 auf, die zweite in B2, bei nur einer bleibt B2 mit "- -" praktisch leer.

Das sind Matrixformeln, das erkläre ich erst nach Rückmeldung. Hab das jetzt noch nicht ausprobiert, ich warte auch damit auf Deine Rückmeldung, vorerst nur mal so ungefähr.

Antwort bewerten Vielen Dank für Deine Bewertung
ReneSaince 11.02.2016, 09:16

Hallo lamiam, hier habe ich die Tabelle mal hochgeladen.

http://www.file-upload.net/download-11297899/KopievonTracking_Bestellungen_Februar09.02.16.xlsx.html

Statusliste DHL wird die Tabelle für den ganzen Monat fortlaufend geführt.
Im Reiter "Sta

0
ReneSaince 11.02.2016, 13:28
@ReneSaince

Ich hänge da jetzt schon seit Stunden dran und brauche die Lösung, um überhaupt die Tabelle weiter ausbauen zu können. Wäre schön, wenn Du mir da eine fertige Formel einbauen könntest und mir paralel die Erklärung lieferst. Normalerweise bin ich eher der Typ, der es solange probiert bis es hinhaut, aber hier habe ich leider zu wenig zeit dazu.

Danke Dir schonmal

0
Iamiam 12.02.2016, 00:13
@ReneSaince

Habe jetzt doch eine Formel auf Basis KKleinste erstellt. Das erste Beispiel für 2 Bestellungen ist Freiburg: Tabelle1, Zeile 70. Formel 

in F70: {=WENNFEHLER(INDEX('Statusliste DHL'!C$1:C$797;KKLEINSTE(WENN(('Statusliste DHL'!B$1:B$797<>"")*('Statusliste DHL'!B$1:B$797=$A70);ZEILE('Statusliste DHL'!B$1:B$797));1);0);"keine")}

in G70: {=WENNFEHLER(INDEX('Statusliste DHL'!C$1:C$797;KKLEINSTE(WENN(('Statusliste DHL'!B$1:B$797<>"")*('Statusliste DHL'!B$1:B$797=$A70);ZEILE('Statusliste DHL'!B$1:B$797));2);0);"- . -")}

die beiden Formeln unterscheiden sich nur  im K für KKleinste (und - unwesentlich-: "- . -" für entfällt anstatt "keine").

Achtung: Dies sind Matrixformeln! Die geschweiften {Klammern} NICHT miteingeben, sondern die Formel anstatt mit einfachem Enter mit der Kombination (gleichzeitig) Strg+Shift+Enter abschließen (nach jeder Neubearbeitung wieder!). Die {Klammern} entstehen dann automatisch.

Schreibtechnisch nimmst Du am besten die rechte Strg- und Umschalttaste, dann gehts mit einer Hand und lässt sich auch leichter merken!  - - -
Noch ein Tipp: Wenn Du in der Bearbeitungszeile einen selbständigen Formelteil markierst und F9 drückst, erhältst Du ein(e) Ergebnis{liste}. Allerdings dann die Zelle mit Esc verlassen (oder rückgängig machen), Enter würde das gezeigte Ergebnis festschreiben! Vorläufig kurze Bereiche festlegen! (mindestens 2 Zellen markieren, Strg+h, ..EndzeileStd.. ersetzen durch ..EndzeileKurz..) --

Bei der ersten (F-) Spalte kannst Du natürlich bei Deinem SVerweis bleibe, ich hab die kompliziertere hier lediglich genommen, um das Prinzip darzustellen.

Das mit dem "Datum nicht identisch" ist hier kein Kriterium, die Formel nimmt einfach die Zeile des zweiten Auftretens desselben Namens und schreibt das zugehörige Datum rechts daneben in Sp.G

Der Klimmzug mit

KKLEINSTE(WENN(('Statusliste DHL'!B$1:B$797<>"")*('Statusliste DHL'!B$1:B$797=$A70);ZEILE('Statusliste DHL'!B$1:B$797));2) ist notwendig, da ansonsten die Leerzellen stören(<>"" ergibt ja Null, und die vielen Nullen sind kleiner als alle anderen Werte. Ein Wenn ohne Sonst-Argument ergibt bei Nichtzutreffen Fehler, und Min, Max, KGrösste und KKleinste ignorieren die Fehler einfach.

Ich hoffe, Du verstehst das Prinzip und kommst damit zurecht.

Wie Du allerdings mit einer DHL-Liererspalte zwei Bestellungen bewältigen willst, weiß ich nicht.Aber die Fpormeln ließen sich ja entsprechend erweitern.

Noch was: Kopiere jede Formel erst ein paarmal einzeln, xl tendiert dazu, Bereichsmatrixformeln draus zu machen, die man nicht mehr ändern kann. In diesem Fall eine Formel als String kopieren, i'wo daneben schreiben und den gesamten Formelbereich löschen. anschließend die kopierte als String wieder einfügen und vervielfältigen wie beschrieben.

Im übrigen würde ich den Bereich kleiner machen, zB bis Zeile 130 anstatt 797 und bei Bedarf neue Zeilen einschieben. Entlastet den Rechner und fördert die Übersicht, wenn Du doch mal F9 zur Formelanalyse verwendest.

Viel Erfolg!

0

Was möchtest Du wissen?