Excel summieren von Feldern mit bestimmten Eigenschaften?

3 Antworten

Nur, damit du siehst, dass es auch noch ganz andere Möglichkeiten gibt, sowas zu berechnen

=SUMMENPRODUKT((I2:I4="")*G2:G4+(I6:I8="")*G6:G8) oder

=SUMMENPRODUKT(istleer(I2:I4)*G2:G4+istleer(I6:I8="")*G6:G8)

Wenn Du Schüler oder Anfänger bist, brauchst du das weder zu verstehen noch anzuwenden. Später empfehle ich, die "Logikformeln" im Zusammenhang mit zB Summenprodukt zu studieren! (die können nicht nur Zählen-/SummewennS() ersetzen, sondern noch viel mehr!

übrigens: genauere Formulierung: jede korrespondierende Zelle in i soll leer sein, nicht eine vom jeweils Zweierblock, wäre ja auch denkbar.

Du hast ein Leerzeichen zwischen den " ", nun erwartet Excel auch ein Leerzeichen !

Probiere es ohne Leerzeichen:

=SUMMEWENN(I2:I4:I6:I8;"";G2:G4:G6:G8)

Das war ja einfach. Danke! :)

0
@Oubyi

So funktionierte es besser, denke ich:

=SUMMEWENN(I2:I4;"";G2:G4)+SUMMEWENN(I6:I8;"";G6:G8)

Wenn Du allerdings sicherstellen kannst, dass in G5 keine Zahl steht, sondern höchstens Text, dann klappt auch:

=SUMMEWENN(I2:I8;"";G2:G8)

Die Formel von Antitroll funktioniert dann aber auch.

2
@Oubyi
Die Formel von Antitroll funktioniert dann aber auch.

Habe die Formel vom Fragesteller 1:1 übernommen, nur das Leerzeichen als Fehlerquelle entfernt ;)

2

ich würde I ... Felder komplett rauslassen aus der Formel wenn sie leer sind

Ich will die Zahlen aber nur dazu addieren, wenn halt dort nichts drin steht. Deswegen frage ich hier ja.

0
@kelliunes

also nochmal, du willst Zahlen addieren die nicht drinstehen? Ich steh da grade auf dem Schauch. Oder soll die Zahlen auch in I erscheinen?

0
@Lotttchens

Wenn das Feld in I leer ist, dann möchte ich die Zahl aus G dazu addieren. Wahrscheinlich verstehst du es nicht, weil meine Formel komplett falsch ist. :D

0
@kelliunes

sorry ich würde gerne helfen , aber scheint schwierig, du meinst der Wert in I ist null?

0

von Null ist keine Rede. LEER ! wie =ISTLEER(i)=WAHR

0
@Iamiam

du willst du nichts, etwas dazu addieren? Mir erschließt sich einfach der Sinn nicht.

0
@Lotttchens

es soll ja nicht i addiert werden, sondern G, aber nur, wenn in i nichts eingetragen ist.

Praktisches Beispiel: in G stehen Ausgaben, in i der Verwendungszweck. Nun willst du wissen, wieviel ohne Angabe des Verwendungszwecks ausgegeben wurde.

(hast du in G5 eine Zwischensumme, ist auch der Ausschluss dieser Zelle klar, denn in i5 steht dann vllt auch nichts, und dann würde die Zwischensumme aller Ausgaben einfach dazuaddiert, was nicht sein darf!

Nur mal so aus den Fingern gesaugt.

0

Was möchtest Du wissen?