Excel: Summewenn funktioniert nicht mehr, da das Vergleichskriterium nicht mehr eindeutig ist.

...komplette Frage anzeigen

1 Antwort

was hindert dich daran, Wildcards vor und nach Initial zu setzen?

=SUMMEWENN(A2:A6;"*Initial*";B2:B6)
summewenn mit wildcards - (programmieren, Microsoft, Excel)
reconciliation1 01.07.2014, 18:11

Keine Ahnung, da stand ich irgendwie total auf dem Schlauch!

Super, danke!

0
Ortogonn 01.07.2014, 18:15
@reconciliation1

Manchmal sieht man den Wald vor Bäumen nicht. Geht da den Menschen wie den Leuten ;)

Gern geschehen.

1
Iamiam 01.07.2014, 23:36
@Ortogonn

"mit Finden zu kombinieren": geht mit Summewenn nicht, aber

=summenprodukt(nicht(istfehler(suchen("initial";A:A;1)))*B:B)

sollte auch gehen, nur als Anregung.
(finden unterscheidet GROSS/klein, suchen nicht, ansonsten gleich!)
Ortogonns Lösung ist auf jeden Fall einfacher!

1
reconciliation1 02.07.2014, 14:54
@Iamiam

Wenn man eine Überschrift mit einem nicht numerischen Wert im Feld B1 hat:

=SUMMENPRODUKT(NICHT(ISTFEHLER(SUCHEN("initial";A:A;1)))*B:B)
ergibt einen Fehler:
#WERT!

so funktioniert es:

=SUMMENPRODUKT(NICHT(ISTFEHLER(SUCHEN("initial";A2:A999;1)))*B2:B999)

1

Was möchtest Du wissen?