Excel: Summenbildung anhand eines Datums - wie kann ich dies auf einfache Weise lösen?

...komplette Frage anzeigen Summenbildung: Externe Bereichsvorgabe - (Mathe, Mathematik, Excel)

2 Antworten

=SUMMEWENNS($I$10:I36;$B$10:B36;">="&D2;$B$10:B36;"<="&D3)
Antwort bewerten Vielen Dank für Deine Bewertung
Suboptimierer 07.01.2016, 14:48

Zu beachten ist, dass wenn du die Summen in derselben Spalte stehen hast wie die zu summierenden Zeiten, du die Summen evtl. mehrfach einrechnest. Entweder darf in Spalte B vor einer Bereichssumme kein Datum stehen oder du musst die Zwischensummen verrücken.

netto und brutto würde ich auch in der Spalte versetzen.

1

solltest du noch ein altes xl haben, das SummewennS nicht kennt, dann gehts auch so:

=SUMMEWENN($B$10:B36;">="&D2;$I$10:I36)
-SUMMEWENN($B$10:B36;"<="&D3;$I$10:I36)


mit ">=" und "<=" werden die Grenzdatümer
miteinbezogen,
birgt in anderen Zusammenhängen
die Gefahr von Doppel
zählungen, normalerweise
lässt man
bei einem der beiden das = weg

Antwort bewerten Vielen Dank für Deine Bewertung
herved 08.01.2016, 00:05

Entschuldigung, ich wurde falsch verstanden: Der Bereich, von dem die Summe zu bilden ist, wird nur durch die Angabe des Start-und des Enddatums definiert und unter Angabe der Spalte, aus der die Summe zu bilden ist. Einfacher wäre doch gleich die Summe über "Auto-Summe" zu bilden.

0
Iamiam 08.01.2016, 09:22
@herved

Die Formel macht nichts anderes: D2 Startdatum (älteres=kleinere Tageszahl), D3 Enddatum.

Anstatt i10:i36 kannst Du auch i4:i436 o.ä schreiben, dann kannst Du eine ganze Jahresliste erfassen und der Bereich wird automatisch erweitert, wenn Du über Zeile 10 (unterhalb von Zeile 4) neue Zeilen einfügst.

Da Du Deine sonstigen Summen (wenn überhaupt noch erforderlich nicht neben einem Datum stehen hat,. werden sie auch nicht mitsummiert.

Was nicht geht: i:i, weil die Summe selbst in Spalte i gebildet wird, das ergäbe Zirkelbezug

1

Was möchtest Du wissen?