Excel Summe ohne negative Zahlen

...komplette Frage anzeigen

3 Antworten

hast es schon mal über Zellen formatieren - Benutzerdefinierte Formatierung probiert? dort schreibst in das weisse Feld: 0,00_ ;

dann sollte, egal wie die Rechnung lautet, kein negativer Wert angezeigt werden.

Habs getestet - bei mir klappts

oder du v erpackst deine Rechnungen in Wenn-Formeln.

Ich hätte das SO gemacht:

=SUMMENPRODUKT((A1:A26)*(A1:A26>0))

Aber wenn Du mit Deiner Lösung klar kommst soll mir das recht sein.

Wenn das Ergebnis eben eine negative Zahl ist dann ist das nunmal so.

iBaer 20.08.2012, 12:57

Intelligenzbolzen.

0
DerCowboy 20.08.2012, 13:00
@iBaer

Dann formuliere deine Fragen am besten zukünftig noch unpräziser.

0
iBaer 20.08.2012, 13:05
@DerCowboy

Ich möchte 3 Rechnungen machen.

  1. 4-3 = 1
  2. 2-3 = -1
  3. 3-3 = 0

-1 ist böse, mag ich nicht, weg damit.

also zu 2.

2-3= 0

Präzise genug?

0
DerCowboy 20.08.2012, 13:11
@iBaer

Nicht wirklich... Aber wenn es darum geht, dass der Wert dort einfach nicht stehen soll machst du einfach eine Formel der Art wenn Zelle <0 dann was auch immer du darin stehen haben willst.

0
iBaer 28.08.2012, 15:05
@DerCowboy

Die Antwort war einfach unnötig. Entweder hilft man sich gegenseitig oder man lässt es. Im Endeffekt hast auch Du eine Lösung gefunden, aber dieser Kommentar war mehr als lachhaft und unnütz.

0

Was möchtest Du wissen?