Excel: summe erreichnen wenn kriterien erfüllt sind (Postleitzahl)

...komplette Frage anzeigen

2 Antworten

Kannst du deine nicht funktionierende SUMMEWENN-Formel präsentieren?

Falls SUMMEWENN(S) nicht weiterhilft, kann man mit SUMMENPRODUKT noch einiges rausholen. Wenn du alle Einträge von B1:B100 addieren willst, bei denen die Einträge in A1:A100 mit "3" beginnen, kannst du folgende Formel verwenden:

=SUMMENPRODUKT((LINKS(A1:A100;1)="3")*(B1:B100))

Iamiam 07.02.2015, 10:36

Hinweis: das kürzere
=SUMMENPRODUKT((A1:A100="3*")*(B1:B100))
geht nicht!
(Zellvergleiche in Matrixformeln lassen keine Wildcards zu,
im Gegensatz zu Vergleich, Summewenn, SVerweis etc!
da muss man ggf über Nicht(istfehler(Finden("3";....))) gehen)

1

Versuche es mal in zwei Schritten: Du machst eine neu Spalte (oder Zeile) auf, in der Du zunächst nur die Addition mit =WENN(...) durchführst. Dann nimmst Du die Summe der dabei entstandene Spalte (oder Zeile). Die Hilfsspalte kannst Du ja später ausblenden.

Vorteil: Du kannst Dir erst die Ergebnis der Umformungen ansehen und schon erkennen, ob die geklappt haben.

Was möchtest Du wissen?