Excel Summe berechnen mit Datennamen?

2 Antworten

Von Experte GutenTag2003 bestätigt

Dafür braucht es kein vba, obgleich es ne schöne Übung wäre.

Du benötigst eine Tabelle deiner Daten. Am besten im pilot tauglich Format.

Auf einer 2ten Seite hast du dann datenvalidierte dropdowns zu deiner Tabelle und ggf ein paar Formeln. Je nach Dropdown wahl kommt dann das entsprechende Ergebnis heraus. Diese Lösung halte ich für schneller umgesetzt und im Anschluss auch leichter erweiterbar.

Dazu brauchst du weder VBA noch Pivot. Wenn deine Preispolitik wirklich so einfach ist, geht das mit einer einzigen Formel:

Kopiere diese Formel in B2 und dann so oft runterkopieren, wie du maximal Positionen haben willst:
=WENNFEHLER(WECHSELN(A2;"Baum";"")*5+9,99;"")
Darunter die Summenformel und fertig. Dabei ist es auch egal ob du Baum1 oder Baum 1 schreibst.

Woher ich das weiß:Eigene Erfahrung – Faulheit >> Neugier >> Wissen
 - (Excel, Formel, VBA)

Was möchtest Du wissen?