Excel Suchen und Ersetzen aus mehreren Werten

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Schade dass Du nur ein Bild hochgeladen hast und kein Excel Datei.
Wäre einfacher gewesen.
Versuche mal in Deiner Datei Folgendes:
Schreibe in D2:

=VERKETTEN(E2;F2;G2;H2;I2;J2;K2;L2;M2)

[Ich habe mal nur bis M geschrieben, Du musst noch weiter machen, wirst gleich sehen warum]
In E2 schreibst Du diese Formel:

=WENN(ISTNV(INDEX($C$1:$C$1000;VERGLEICH(TEIL($A2;SPALTE(A1)*8-7;6);$B$1:$B$1000;0)));TEIL($A2;SPALTE(A1)*8-7;8);INDEX($C$1:$C$1000;VERGLEICH(TEIL($A2;SPALTE(A1)*8-7;6);$B$1:$B$1000;0))&", ")

und -WICHTIG- kopierst/ ziehst sie weiter nach rechts und zwar soviele Spalten, wie Du maximal Einträge in Spalte A hast. SOWEIT musst Du dann auch das Verketten in D2 weiterschreiben.
Jetzt steht in E2 bis BX2 oder wieweit Du gegangen bist immer EIN Ersatz für EINEN Eintrag, falls einer in der Liste in B1:C1000 vorhanden ist, sonst steht das alte Kürzel da.
In D2 werden dann diese Zellen verkettet.
Die Spalten E bis Ultimo kannst Du - wenn Du willst - ausblenden.
Oder, falls das eine einmalige Angelegenheit ist, kopierst Du die Spalte D und fügst sie sofort wieder ein über: Inhalte einfügen... / WERTE.
Danach kannst Du die Hilfsspalten löschen.
Kommst Du klar?
Sonst lade vielleicht doch mal einen Teil als .xls-Datei hoch.

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Ich habe KEINE AHNUNG wie Du auf diese Formel kommst, aber Sie funktioniert ^^

Vielen vielen Dank. Du hast mir bestimmt 2 Wochen Suchen und Ersetzen erspart :-)

0
@Torkim

Freut mich, dass ich helfen konnte ☼

0
@Oubyi

wenn es möglich wäre, würde ich Dir dafür 3 DHs geben!
Auf sowas wär ich NIE gekommen! (habs auch noch nicht ganz verdaut!)

0

warum in Spalte A nach Werten in B suchen?

Aber ich hätt ne Variante, da brauchst allerdings noch ne Spalte D, damit die bisherigen Werte nicht überschrieben werden - versuchs mit ner Wenn-Funktion

=wenn(B3="Suchtext";C3;"")

Wenn nach Text gesucht werden soll, musst den in Anführungszeichen setzen, bei nur Zahlen sind die nicht erforderlich..

Damit aus der Aufzählung in A ein Beschreibungxtext wird.

Danke für die Formel. Aber bei der muss ich ja "Suchtext" durch jeden Wert aus Spalte B ersetzen. Wie kann ich machen, dass er Spalte B zeile für zeile durchgeht?

0

Was möchtest Du wissen?