Excel: =suchen und =rechts / =links verbinden

...komplette Frage anzeigen

1 Antwort

Bist Du sicher, dass Du für diese Aufgabe die LINKS / RECHTS Formeln benutzen sollst?
SO:

   =TEIL(A1;FINDEN("opqrst";A1)+2;4)    

wäre es am sinnvollsten, wenn ich Dich richtig verstanden habe ("nach von rechts haben" ist nicht wirklich verständlich).

Oubyi 12.11.2010, 12:10

Oder vielleicht so:
=RECHTS(LINKS(A1;FINDEN("opqrst";A1)+5);4)
Wie gesagt den Sinn sehe ich nicht!

0
Oubyi 12.11.2010, 12:15
@Oubyi

Oder so:
=RECHTS(LINKS(A1;FINDEN("opqrst";A1)+LÄNGE("opqrst")-1);4)
Das macht aber, wenn überhaupt, nur Sinn, wenn "opqrst" veränderlich in einer Zelle steht.

1
augsburgchris 12.11.2010, 16:08
@Oubyi

Oder so: =RECHTS(LINKS(A1;FINDEN("opqrst";A1)+LÄNGE("opqrst")-FAKULTÄT(1)*WAHR);WURZEL(16))

:-)

0
itfutzi 13.11.2010, 13:42
@Oubyi

=RECHTS(LINKS(A1;FINDEN("opqrst";A1)+5); 4) macht absolut sinn!

0
Gimly 13.11.2010, 14:51
@itfutzi

Oha, also mein Lehrer hat mir das ganze nochmal erklärt, er meinte das eher so, dass ich jetzt zum Beispiel eine Liste von Postleitzahlen und den dazugehörigen Städten untereinander habe und jetzt funktionen so eingebe, dass daneben eine liste ist mit nur der postleitzahl und daneben dann nochmal mit nur der stadt eine liste. Um das dann so zu machen brauche ich dann aber noch die =anzahl funktion (oder wie die auch immer heißt^^). naja, danke auf jeden fall für eure antworten ^^

0
Oubyi 13.11.2010, 15:24
@Gimly

Nicht ANZAHL, sonder LÄNGE!
Wenn die Postleitzahlen immer fünfstellig und durch ein Leerzeichen getrennt sind, dann:
=LINKS(A1;5)
=RECHTS(A1;LÄNGE(A1)-6)

0
Suboptimierer 10.03.2016, 14:51
@itfutzi

@itfutzi: Das sieht wie vom ersten Kommentar abgeschrieben aus. 

In der Ursprungsantwort steht +2, was denke ich mehr der Fragestellung entspricht.

0
Suboptimierer 02.03.2017, 11:46
@Oubyi
=RECHTS(LINKS(A1;FINDEN("opqrst";A1)+5);4)

Statt der letzten 4 könnte man noch LÄNGE("qrst") schreiben. ;)

Aber wenn bei Fund des Suchbegriffs sowieso ein Teil des Suchbegriffs zurückgegeben werden soll, würde fast schon schlicht reichen:

=WENN(ISTFEHLER(FINDEN(...);"";"qrst")
1

Was möchtest Du wissen?