Excel: String als Bezug

1 Antwort

Indirekt() ist ziemlich sicher der falsche Ansatz. Bereich.Verschieben() wird es wohl sein. Versteh aus der Beschreibung aber nicth was du erreichen willst um ein Beispiel zu geben

Ich möchte eine Übersicht aus mehreren Tabellen erstellen. Dazu suche ich über einen Key die Daten aus den Tabellen zusammen. Die Übersichtstabelle hat dann Überschriften wie tbl1-inhalt, tbl2-strasse und tbl3-plz. Nun benenne ich in den einzelnen Tabellen die Spalten so, wie sie laut Übersicht heißen sollen, also tbl1-inhalt, tbl2-strasse und tbl3-plz. In der Übersicht werden dann automatisch die richtigen Werte angezeigt. Momentan muss ich jedoch für jede Spalte die Formeln einzeln erstellen, wie oben angegeben.

0

Ok, ich habe es nun wie folgt gelöst:

WENN(ISTFEHLER(SVERWEIS(key;tbl1databykey;VERGLEICH(INDIREKT(ADRESSE(1;SPALTE()));tbl1header;FALSCH)-1;FALSCH));SVERWEIS(key;tbl2databykey;VERGLEICH(INDIREKT(ADRESSE(1;SPALTE()));tbl2header;FALSCH)-1;FALSCH);SVERWEIS(key;tbl1databykey;VERGLEICH(INDIREKT(ADRESSE(1;SPALTE()));tbl1header;FALSCH)-1;FALSCH))

Das heißt ich schaue nach der Überschrift, finde diese dann in der ersten Tabelle und suche dort per SVERWEIS den dazugehörigen Wert raus. Wenn das fehlschlägt, dann suche ich die entsprechenden Daten in der zweiten Tabelle. Und wenn das auch fehlschlägt, dann wird mir der Fehler von Tabelle 2 angezeigt. Die xxheader sind jeweils die erste Zeile der Tabellen, während die xxdata die Datenbereich mit dem Key an erster Stelle darstellen. Trotzdem danke für die Hilfe ;)

0

Mit Autohotkey aus Excel kopieren und in ein anderes Programm einfügen?

Hallo zusammen,

Ich würde gerne den Inhalt in einer Excel Datei in ein anderes Programm einfügen.

Beispiel: Ich habe eine Liste mit Daten in Spalte A und Spalte B.

Das Skript soll mir als erstes den Inhalt aus Spalte A Zeile 1 kopieren, in das andere Programm XY springen und in eine bestimme Zelle einfügen.

Danach soll es wieder nach Excel springen und diesmal den Inhalt aus Spalte B Zelle 2 kopieren und in das andere Programm einfügen.

Danach soll in dem anderen Programm ein Button angeklickt werden als Beispiel der "speichern" Button.

Anschließend soll wieder nach Excel gesprungen werden und diesmal die Spalte A Zeile 2 kopiert und eingefügt werden usw. bis die Liste fertig ist und in Spalte & Zeile kein auszulesender Inhalt mehr vorhanden ist.

Ich bin mega Neuling und würde mich freuen wenn mir jemand ein kurzes Skript hierzu schreiben könnte.

Danke im Voraus.

...zur Frage

Excel: Formel wird nicht erkannt sondern als Text ausgeschrieben

Hallo GuteFrage,

ich verweise in einem Excelreiter auf andere Excelreiter innerhalb derselben Datei, ganz simpel zB. mittels ='Sheet2'!D2.

Bei einigen Spalten gelingt das und es steht dann der Wert / Inhalt der Zelle D2 aus Sheet 2 dort. Bei anderen Spalten allerdings steht dann nur mein Verweis in der Zelle, zB. ='Sheet2'!E2. Excel scheint meinen Verweis nicht als Verweis zu erkennen. Woran kann das liegen? Die Zellen sind alle gleich formatiert.

Viele Grüße

...zur Frage

Excel soll nach Löschung auf die selbe Zelle zugreifen.

Hallo, ich habe zwei Blätter in Excel. Blatt 1 ist eine Bestätigung für eine Anmeldung. Die ganzen Daten, aus denen diese sich speist habe ich in einem anderen Blatt. Ich drucke dann die Bestätigung aus. Das funktioniert soweit alles super. Nur zeigt Excel mir #BEZUG! an, wenn ich im zweiten Blatt die erste Zeile lösche, damit die Daten der zweiten nachrücken können. Ich habe (bei einfacheren Formeln INDIREKT davor eingegeben. Das klappt auch. Das Problem, das ich habe ist, dass ich eine Zelle habe, die so aussieht:

=WENN(ISTLEER(Tabelle2!D2);"";(Tabelle2!D2))

Wie kann ich das so eingeben, dass Excel auch nachdem ich die erste Zeile im anderen Blatt gelöscht habe (und die zweite Zeile nachrückt) dann den neuen Wert aus D2 berücksichtigt? Wenn ich einfach INDIREKT davor schreibe, kommt Excel damit auch nicht zurecht. Ich hoffe, ich konnte das Problem gut schildern.

ps: Das selbe tritt bei folgenden Formeln auf:

=WENN(ISTLEER(Tabelle2!D2);"";"X") =WENN(ISTLEER(Tabelle2!D2);"X";" ")

...zur Frage

Excel von bis Summen, Produkte etc.?

Hallo zusammen,

die Frage klingt vielleicht doof, aber mein Problem ist eigentlich relativ einfach.

Ich habe spalte A in der stehen Zahlen aufsteigend von 1 - unendlich Spalte b stehen zahlen

nun möchte ich in einem getrennten Bereich angeben, rechne alles zusammen was zwischen z.B. Zeile 12 und 25 steht, ob jetzt multiplizieren, subtrahieren oder addieren ist ja erstmal wurscht.

Dazu habe ich eine Zelle mit VON in der ich die Zeile angeben und BIS in der ich die Zeile angebe, hinten dran werden dann noch Maximalwerte, Minimalwerte und Durchschnitt etc. gebildet.

so eine echte Idee hatte ich bisher nicht, wie ich der summenformel oder anderen Formeln diese Infobeibringen kann oder kann ich das Zeilennummer innerhalb einer Formel durch einen Verweis auf eine andere Zelle einfügen mal ganz simpel ausgedrückt in etwa so?

=summe(A(F9):A(G9)) ich weiß das diese nicht funktioniert aber ich denke hiermit das Prinzip dargestellt zu haben, was ich erreichen will.

Vielen Dank an alle helfenden schon einmal.

...zur Frage

Excel ZÄHLENWENN mit relativen Bezug auf Zelle oberhalb der aktuellen

Hallo,
Ich habe eine Tabelle, in der ich die erste Spalte auf Duplikate überprüfen möchte.
Dazu sorteiere ich diese Spalte (alles Zahlen) in aufsteigender Reihenfolge und möchte nun die "Zählenwenn"-Funktion verwenden, um die Duplikate zu zählen.
Da die Spalte ja sortiert ist kann ich sicher sein, dass gleiche Zahlen immer übereinander liegen, sodass ich in der "Zählenwenn"-Funktion folgendes haben möchte:

=ZÄHLENWENN(Bereich;Inhalt=Inhalt der Zelle oberhalb)

Die Zählenwennfunktion durchläuft ja alle Zellen im Bereich, weshalb (theoretisch) die Funktion "Adresse()" mit "Zeile()" und "Spalte()" als Parameter die aktuelle Zelle referenzieren/sich darauf beziehen.
Das würde bedeuten, dass ich in der "Zählenwenn"-Funktion als zweiten Parameter eigentlich nur folgendes eingeben müsste:

Adresse(Zeile()-1;Spalte())

Funktioniert nicht.
In einigen Beispielen habe ich gesehen, dass Bezüge auf andere Zellen in der "Zählenwenn"-Funktion mit einem "&" beginnen, also habe ich folgendes versucht:

=ZÄHLENWENN(A2:A3000;&ADRESSE(ZEILE()-1;SPALTE()))

Wieder kein Erfolg.

Deshalb die Frage: Wie kann ich in der "Zählenwenn"-Funktion in Excel mich auf eine Zelle, relativ zur aktuellen beziehen? Das hier genannte Beispiel wird sicher auch anders zu lösen gehen, aber den genannten relativen Bezug (also relativ zur Aktuellen Zelle) könnte man in der Zählenwenn schon öfters brauchen. Danke und lg, Springrbua

...zur Frage

Excelformelfehler beim Summieren von Werten aus Zellen, welche aus Formeln bestehen & z.T. leer sind

Hallo,

ich brauche mal Excel Hilfe... Vielleicht schau ich einfach schon zu lange auf diese Liste und denke zu kompliziert, dass ich selbst auf die Lösung nicht komme :)

Ich bekomme den Fehler "#WERT!" angezeigt, wenn ich die Summe aus diversen Zellen ziehen möchte. Die Werte in den Bezugszellen ergeben sich aus hinterlegten Formeln. Diese Formeln besagen auch, wenn XY="";"";rechne bsp.: =WENN($J267="";"";ZÄHLENWENN(E267:I275;">0"))

Auf Grund dieser hinterlegten Formeln, rechnet mir Excel nun nicht die Summe aus den Ergebnissen dieser ganzen zu addierenden Zellen zusammen. Liegt es daran, dass die Bezugzellen Formeln drin haben, oder liegt es daran, dass einige Bezugszellen (auf Grund dem Formelbefehl) leer sind? Falls ja, was kann ich ändern, dass er mir dennoch die Werte zusammen addiert?

Ich hoffe ganz stark auf eure Hilfe.

Vielen Dank dafür :)

...zur Frage

Was möchtest Du wissen?