Excel Spaltennuimmer bestimmen?

...komplette Frage anzeigen

3 Antworten

Eine funktionierende Lösung, wenn auch etwas holzhammerig ist diese:

=SUMMENPRODUKT((A1:A99=F1)*(B1:B99=G1)*1
+(A1:A99=F1)*(C1:C99=G1)*2
+(A1:A99=F1)*(D1:D99=G1)*3
+(A1:A99=F1)*(E1:E99=G1)*4
+ usw.)

In diesem Beispiel stehen die Baustoffe in Spalte A, die Klassen in den Spalten daneben. Der gesuchte Baustoff und die Klasse stehen in F1 und G1. Je nachdem, wieviele Klassen-Spalten es gibt, muss die Formel entsprechend erweitert werden. Mit jeder nächsten Spalte steigt der Spaltenmultiplikator um 1.

Nayes2020 18.07.2016, 12:16

Ey das ist ja Mega schlau. Die Spalten werden einfach addiert bis zu dem gesuchten. so habe ich das verstanden?

ich verstehe es nicht soo ganz aber ich schau mal was ich da deichseln kann. Vielen dank

0
DeeDee07 18.07.2016, 12:30
@Nayes2020

Der Formelteil (A1:A99=F1)*(B1:B99=G1) multipliziert alle Einträge zusammen, wobei zutreffende Aussagen 1 sind und nicht zutreffende 0. Genauso bei den übrigen Formelteilen.

Wenn also der Baustoff vorhanden ist (was bei korrekter Sucheingabe gegeben ist) und die gesuchte Klasse in dieser Spalte ist, wird das Ergebnis 1 sein, sonst 0. Dieses Ergebnis wird dann mit dem Spaltenfaktor multipliziert. Da die gesuchte Klasse ja nur in einer Spalte der gesuchten Zeile vorkommen kann, wird nur ein Formelteil >0 sein.

Etwas vereinfacht dargestellt: Wenn die gesuchte Klasse z.B. in der 3. Spalte (im Beispiel D) ist, wird das Ergebnis
0*1 +0*2 +1*3 +0*4 = 3 sein.

1

Ohne den Aufbau der Tabelle zu kennen wird es schwer genau zu helfen.

Im Grunde gibts es 2 Methoden:

- wenn die Normalbetone in einem komplett anderen Bereich liegen, kann man diesen mittels Bereich.Verschieben zuordnen

- falls alles in einer Tabelle Steht hat man eben nicht nur ein Auswahlkriterium sondern 2. Also die Klassische Kombination von 2 Bedingungen beim Sverweis.
Diese kann man mittels Wenn oder mittels Zellenverknüpfung & erreichen.

Nayes2020 18.07.2016, 09:32

Alle baustoffe und Rohdichteklassen sind in einer großen Tabelle.

Im vorfeld wird über Dropdown (Datenüberprüfung und Namensmanager)  Baustoff und Rohdichte bestimmt.

Sverweis will nicht funktionieren:

bei Suchkriterium habe die zelle ausgewählt wo die Rohdichte ausgewählt wurde.

bei Matrix habe ich in der Tabelle alle Rohdichten ausgewählt. Also alle möglichen Werte

Bei Zeilenindex habe ich eine Zelle ausgewählt wo die Nummer der Zeile steht. diese Zahl ist über VERGLEICH entstanden. Da ja die Baustoffe eimalig und in einer Reihe sind passt das.

und am ende noch falsch angegeben.

Er weiß also welcher Wert gesucht werden muss in welcher Zweile und in welcher Matrix. trotzdem kommt NV raus

0
Nayes2020 18.07.2016, 09:36
@Nayes2020

Ich kenne auch Sverweis nur für 2 Spalten. die eine wo der gesuchte Wert steht und die andere Spalte wo das Suchkriterium sich befindet

Die Tabelle hat aber nicht nur 2 Spalten, weil es ja nicht nur eine Rohdichte gibt sondern mehrere.

0

Du könntest für jeden Baustoff eine Verweistabelle machen und dann mit einem Sverweis innerhalb einer wenn-funktion arbeiten. Also "=WENN("Leichtbeton";Sverweis(...);WENN("Normalbeton";SVERWEIS(...)...

das geht natürlich nur bis zu einer bestimmten Zahl an Bausstoffen. Weiß nicht wie viele du da hast. für deine zwei würde das ja reichen

Nayes2020 18.07.2016, 09:11

Es ist eine große Liste. Da ich im Prinzip jede Art von Baustoff in der Liste habe.

es ist sehr umfangreich

0
Jackie251 18.07.2016, 09:26

Die kombination von Wenn und Sverweis muss man dann auch andersherum nutzen!
Also zB
=SVERWEIS(Suchkriterium1;WENN((B1:B10 =Suchkriterium 2);A1:C10);3)

wobei dann Suchkreterium 1 im Bereich A1:A10 gesucht wird - jedoch nur wenn Suchkriterium 2 im Bereich B1:B10 vorhanden ist.

0

Was möchtest Du wissen?