Excel Spalte auslesen?

Beispiel - (programmieren, Excel)

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Probier mal

=SUMMENPRODUKT(((A1:A10&B1:B10="AB")+(A1:A10&B1:B10="BA"))*(C1:C10="A"))

1

Klappt ebenfalls wunderbar, vielen Dank!

0
35

summenprodukt löst gefühlt die Hälfte aller Probleme und Sorgen mit Excel

0
42
@Ninombre

Ja. Wobei man auch kürzer

{=SUMME(((A1:A10&B1:B10="AB")+(A1:A10&B1:B10="BA"))*(C1:C10="A"))}

verwenden könnte. Aber dann muss man noch den Umgang mit Matrixformeln erklären :)

0
40
@DeeDee07

wobei ZählenwennS wahrscheinlich die geforderte Lösung wäre, aber da wir hier keine Hausaufgaben bearbeiten wollen, sehe ich auch Summenprodukt als die "fortschrittlichste" Lösung an, die ich auch für eigene Probleme -Pardon: natürlich Herausforderungen!-  bevorzuge! (bei uns im Konzern war das Wort Problem verboten, es gab nur "challanges")

0

Mach doch eine Hilfsspalte, in Spalte D, in der die 3 Buchstaben aus den 3 Spalten A, B, C zusammen in 1 Zelle sind.
Dazu gibst du in Zelle D1 die Formel =A1&B1&C1 ein und kopierst die Formel runter. In D1 steht dann "ABA", in D2 steht dann "DDD", und so weiter.

Deine "Zählenwenn-Formel" beziehst du dann auf Spalte D und gibst als Vergleichswert "ABA" ein.

Wenn dich die Hilfsspalte in der Ansicht stört, kannst du sie ausblenden.

1

Super, funktioniert. Danke!

0
42

Die Formel sollte lt. Aufgabe aber auch "BAA" zählen, oder?

0
1
@DeeDee07

Ist richtig, diese Variante hätte ich noch ein wenig modifizieren müssen

0

Ich bin mir nicht sicher ob das auch mit Buchstaben klappt aber es wenn du diese Reihe auswählst dann ist oben so eine leite da musst du dann z.B. =C1:C10 eingeben und dann Enter drücken! Hoffe es klappt bei dir, da ich nicht weiß ob es mit Buchstaben auch geht! Kannst mir ja bitte Bescheid sagen ;)

1

Danke für die Antwort, aber ich glaube das löst mein Problem nicht. Ich habe kein Problem damit, eine Spalte auszuwählen, sondern eher die Formel zu erstellen um das o.g. Ergebnis zu bekommen :)

0

Excel: Wenn Zelle ungleich null, Zeilennummer angeben

Hallo!

Ich habe ein kleines Excel-Problem: Meine Tabelle enthält viele Zeilen mit mehreren Spalten. Spalte E werden manchmal Werte im Plus-/Minusbereich eingegeben. Ich möchte nun im Tabellenkopf zählen a) wie oft in der Spalte ungleich null rauskommt (habe ich schon gelöst) und b) in welcher Zeile kam zum ersten mal ungleich null vor, Ausgabe dieser Zeile Spalte D

Kann mir jemand bei der Lösung von b) helfen?

...zur Frage

Excel - Wenn Wert in Spalte = x, dann Nachbarzelle kopieren

Hallo,

lässt sich folgende Aufgabe über eine Formel lösen?

Wenn ja, wie lautet die Formel?

Ich habe in Spalte A Texte und in Spalte B dazugehörige Zahlenwerte.

In Spalte C stehen stehen die gleichen Texte wie in Spalte A, nur in einer anderen Reihenfolge.

Wenn nun z.B. in Spalte A der Text in der Zelle A3 = "xy" steht, soll der dazugehörige Zahlenwert in Zelle B3 = "365" zu dem passenden Tex in Spalte C gezählt werden.

Also wenn "xy" in Zelle C10 steht, muss der Wert aus B3 = "365" in D10 eingetragen werden.

Ich hoffe es ist verständlich ausgedrückt.

Danke & Gruß Peter

...zur Frage

Excel nächste freie Zelle in Spalte ermitteln?

Hallo,

wie kann ich in Excel aus Tabellenblatt 1 bestimmte Daten aus der neu beschriebenen Zeile (Zeile n, Spalte B, C, E F) in Tabellenblatt 2 transferieren und dort in die nächsten freien Spalten einfügen (Spalte n, A, B, C, D)?

...zur Frage

Wie kann ich in Excel eine Zählenwenns-Funktion oder eine Summenprodukt-Funktion mit einer Oder-Bedingung verknüpfen?

Sachverhalt: In den Spalten A, B und D stehen die Angaben "sehr wichtig", "eher wichtig", "eher unwichtig" oder "unwichtig". In Spalte C steht entweder "pro" oder "contra". Die Befragungsergebnisse - also Zeilen - sollen nur gezählt werden, wenn entweder in Spalte A oder in Spalte B entweder die Angabe "eher wichtig" oder die Angabe "sehr wichtig" steht und wenn zudem in Spalte C "pro" und in Spalte D entweder "sehr wichtig" oder "eher wichtig" steht.

Bsp.: Wenn in Spalte A die Angabe "unwichtig" steht, aber ich Spalte B die Angabe "eher wichtig" und wenn zudem in Spalte C "pro" und in Spalte D "sehr wichtig" steht, soll dieses Befragungsergebnis (diese Zeile) gezählt werden.

Würde bspw. jedoch weder in Spalte A noch in Spalte B "eher wichtig" oder "sehr wichtig" stehen, würde diese Zeile nicht gezählt werden, unabhängig davon, welche Angaben sich in den übrigen Spalten wiederfinden.

Mit welcher Formel kann ich das Problem lösen? Ich wollte in eine Zählenwenns-Funktion Oder-Bedingungen einfügen, aber das hat leider nicht funktioniert.

...zur Frage

Excel: Mehrere Zeilen zu einem Datensatz "erklären"

Ich möchte in excel mehrere Zeilen zu einem Datensatz erklären: Die tabelle sieht wie folgt aus:

Zeile 1:Kundennummer1 | Name | Anschrift | Auftrag 1 Zeile 2 Spalte 4: Auftrag 2 Zeile 3 Spalte 4: Auftrag 3 Zeile 4Spalte 4: Auftrag 4

excel soll erkennen, dass zeilen Aftrag2 bis 4 zu kunde 1 gehören

...zur Frage

Excel Tabelle Differenz bilden?

Hallo Leute!

wie kann ich in Excel eine Tabelle mit 3 Spalten ABC erstellen von denen immer die Zeilen z.B. B1-A1=C1 ausgebgeben werden, aber dass ich diese Formel nicht überall hinschreiben muss. Gibt das da einen Weg? Sowas wie jede Zeile der Spalte B - jede Zeile der Spalte A = dazugehörige Zeile in Spalte C.

Soll für eine Art Fahrtenbuch dienen und ständig erweitert werden können ohne immer die Differenzformel anzugeben.

Mfg

Lazarys

...zur Frage

Was möchtest Du wissen?