Excel Sheet Problem! Hilfe?

...komplette Frage anzeigen Tabelle - (Windows, Excel, Office)

1 Antwort

Kannst du den Rollen IDs zuweisen? CD=1, CB=2,...

Dann könntest du die Tabelle auf ein neues Blatt kopieren, alle FALSCH durch 0 ersetzen (Strg + h), alle CD durch 1, CB durch 2,...

Oder per Formel mit dem VERGLEICH: =WENNFEHLER(VERGLEICH(B3;{"CD";"CB";"XY";"ZZ"};0);0)

____

Im nächsten Schritt kannst du mit Datenkonsolidierung spielen (Maximum) oder du legst eine Datenverbindung an. Daten → Verbindungen → Hinzufügen → Nach weiteren Elementen suchen → *.xlsx → aktuelle Arbeitsmappe auswählen → Quelltabelle auswählen (am besten benamter Bereich)

Achte darauf, ob die Überschriften mit kommen. Wenn nicht, musst du in der Verbindungszeichenfolge HDR=NO eintragen.

Schließe die Dialoge. Im Excelsheet wählst du Daten → Vorhandene Verbindungen → Verbindungen in dieser Arbeitsmappe → <die gerade angelegte Verbindung>

Auf der eingefügten Tabelle machst du einen Rechtsklick und fügst eine SQL-Abfrage unter Tabelle → Abfrage bearbeiten ein.

Muster:

select f1, max(f2) as Titel1, max(f3) as Titel2, max(f4) as Titel3, count(*) from unkumuliert group by f1

Wenn du willst, kannst du jetzt die Rollen rückübersetzen. Du kannst die Tabelle auch unter Rechtsklick → Tabelle → In Bereich konvertieren fixieren.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von SirRob
23.03.2016, 15:46

Danke erstmal für deine ausführliche Antwort, leider sind die "FALSCH" durch eine Funktion erzeugt und können somit nicht mit strg+h ersetzt werden (findet keine Ergebnisse). "CD" "CB" etc. sind ebenfalls mittels dieser Funktion von einem anderen Sheet geholt und können so auch nicht ersetzt werden ...

0

Was möchtest Du wissen?