Excel-Rechnungen Subtraktion bis Zahl <= 25?

...komplette Frage anzeigen

5 Antworten

Die Lösung in Listenform:

A1: Eingabe deiner Zahl (hier 140)
B1: Subtrahend (hier 25)
A2: =WENN(A1<>"";WENN(A1-$B$1>=0;A1-$B$1;"");"")
C1: =Anzahl(A:A)-1
D1: =MIN(A:A)

A2 herunterziehen

Dazu gibt es das Konzept der Division mit Rest.

140=25*k+l

k mal passt 25 in 140 und l bleibt übrig (der Rest).

Den Rest bekommst Du in Excel so:
=REST(140;25)

wie oft 25 in 140 reinpasst, kannst Du jetzt direkt berechnen, in dem Du die erste Formel umstellst:

k=(140-l)/25

In Excel also

=(140-REST(140;25))/25

Das eine ist Rest:
=rest(140;25) = 15

Die Formel ist m.E. selbstsprechend - der Rest, der bei der Division durch 25 halt übrigbleibt.

das andere =Ganzzahl(140/25) = 5

Gehe da umgekehrt ran:

Anz = GANZZAHL(140 / 25)

x = 140 - (Anz * 25)

Was möchtest Du wissen?