Excel programmieren Buchstabe=Zahl?

5 Antworten

Hallo,

je nach Wert den du zuweisen willst, kannst du hier mit ZÄHLENWENN() und SVERWEIS(), oder nur ZÄHLENWENN() arbeiten.

Folgender Aufbau:

Max Mustermann
X
X
X
X
X
X
...

So, hier haben wir also 6x das "X" von Zeile A2 - A7!

Jetzt kannst du mit folgender Funktion die X in der Spalte zählen und als Zahl ausgeben lassen:

=ZÄHLENWENN("X";A2:A7) 

Andere Möglichkeit wäre die Funktion VERGLEICH()

=VERGLEICH("x";A2:A7)

VERGLEICH() wäre meiner Meinung nach die bessere Lösung, da hier Key Sensitive entfällt.

D.h. Groß- und Kleinschreibung wird hier nicht beachtet und falls du ein x klein oder groß schreibst, funktioniert die Funktion Trotzdem :p

Wenn du dem Wert "X" eine andere Zahl zuweisen willst, Multiplizierst du am ende einfach dein Ergebnis mit der Zahl, oder du arbeitest nebenbei mit SVERWEIS() was aber unnötig wäre.

Angenommen du willst haben das x=5 ist, dann machst du

=VERGLEICH("x";A2:A7)*5

und bekommst 30 als Ausgabe :)

Grüße,

iMPerFekTioN

du macht ein sverweis das x= 1 bedeutet.

am ende der spalte machst du =SUMME

er zählt dann die 1er zusammen und gibt am ende die summe daraus. leer bedeutet dann 0 und wird somit nicht addiert.

die prozentzahl kannst du auch programmieren indem du in die prozentformel einfach =SUMME eingibst.

Dafür eignet sich die Funktion "zählenwenn". Das Ergebnis kannst du nach deinem Gusto formatieren.

Excel: Zählenwenn Zelle mit der Zahl "x" beginnt?

Ich benötige einmal Hilfe bei Excel? Ich habe eine Excel-Tabelle in der 141 Zeilen mit verschiedenen Postleitzahlen.

Jetzt will ich mit mit Excel eine Auswertung machen wie viele PLZ mit der Zahl z.B. 9 beginnen.

kann mir jemand helfen?

...zur Frage

Excel - Pivot Tabelle ohne "rechnen" - einfache Auflistung möglich?

Guten Tag - und zwar brauche ich eine Tabelle... habe folgende Daten:

Unternehmensname Umsatzkategorie (eine Zahl) und Potenzialkategorie (ein Buchstabe)

Nun habe ich diverse Unternehmen die also eine Zahl und einen Buchstaben haben.

Jetzt will ich da eine simple Kreuztabelle haben, horizontal die ZAHL, vertikal die Buchstaben - und in die Felder "in der Mitte" sollen die Unternehmen aufgelistet werden.

Das geht ja prinzipiell mit Pivot Tabellen.. ich kriege es auch hin dass er mir zählt wieviele es pro Paar (Zahl/Buchstabe) gibt - aber ich weiß nciht wie ich es schaffe dass er ir die Namen da hinschreibt :-/

Da sich die Zahlen und Buchstaben öfter ändern macht es keinen sinn so eine Tabelle zu basteln.. das sollte irgendwie automatisch passieren. Ein Excel-Profi eine Idee? :-) Danke!!

...zur Frage

Excel Tabelle Zelle färben wenn Zahl 1,2 usw?

Wie lautet die Formel für folgende Excel Tabelle:

Die Zelle soll sich färben, wenn die Zahl 1 dann grün, bei Zahl 2 braun, bei Zahl 3 lila usw.

wie kann man das machen?

danke

...zur Frage

Welche Excel Funktion benötige ich?

Hallo,
Ich wollte mit Excel eine Tabelle erstellen in die man Buchstaben einträgt und mir dann angezeigt wird (Ideal wäre würde sich das Kästchen, wo der Buchstabe rein geschrieben wird dann grün oder rot färben) ob es falsch oder richtig ist.
Ich weiß aber leider nicht welche Excel Funktion ich dafür benötige habe.
Habe schon mit wenn- und und-Funktion versucht.
Wenn es noch fragen zum Verständnis gibt bitte einfach fragen.

Danke im Voraus Julian :)

...zur Frage

Welche Excel-Funktion ist die richtige für mein Programm?

Hallo,
Ich hatte ja vorhin schonmal unverständlich gefragt.
Ich wollte gerne eine Tabelle erstellen bei der ich in verschiedene Zellen verschiedene Zahlen eintragen will z.B. A1 gebe ich dann C ein und das soll mir dann Excel sagen ob C in diese Zelle muss also ob es richtig is oder ob ein anderer beliebiger Buchstabe rein muss also es wäre falsch und würde sich im Idealfall auch dann so färben.
Also brauch ich eine Formel die sieht welchen Buchstaben ich eingebe prüft ob der mit dem Buchstaben übereinstimmt der in diese Zelle rein muss und es mir dann anzeigt.

Danke im Voraus Julian :)

...zur Frage

Was muss ich bei excel eingeben, wenn ich wissen welche zahl und wie oft sie vorkommt?

Hallo ihr lieben,

ich brauche bitte eure Hilfe.

Es geht um die Häufigkeit einer Zahl in einer Excel tabelle. Ich möchte gerne wissen welche zahlen und wie oft sie in der Excel-tabelle vorkommen. Also ich habe mehrere Zahlen und möchte nur wissen welche zahl wie oft auftaucht.

kann mir bitte jemand dabei helfen :-)

Vielen Dank

...zur Frage

Was möchtest Du wissen?