EXCEL, Problem mit Funktion =ZÄHLENWENNS?

... komplette Frage anzeigen

2 Antworten

Die Lösung des Problems ist simpel und war (etwas versteckt) in der Excel-Online-Hilfe zu finden.


Die Bedingung mit Zellbezug muss zum Beispiel folgende Syntax haben:

">"&F3

- Der Vergleichsoperator steht in Anführungszeichen "<" ">" "="

- Dem Zellbezug steht ein -> & <- voran, dann erkennt Excel, dass es sich um einen Zellbezug handelt

Die Formel lautet also vollständig:
=ZÄHLENWENNS($A$3:$A$1514;">"&F3;$A$3:$A$1514;"<"&G3)

Die Funktionsformel sucht im Bereich "A3 bis A1514" nach der Häufigkeit des Auftretens eines Eintrages, der größer ist als der Wert in "Zelle F3" und kleiner als der Wert in "Zelle G3"

Antwort bewerten Vielen Dank für Deine Bewertung

sorry hab mist geschrieben...

Zellen formatieren wahrscheinlich liegts daran

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von visitar
15.06.2016, 00:47

Sorry ! NEIN !
Aus der EXCEL-Hilfe:

"Syntax

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2]…)

Die Syntax der Funktion ZÄHLENWENNS weist die folgenden Argumente auf:

Kriterienbereich1    Erforderlich. Der erste Bereich, in dem die zugehörigen Kriterien ausgewertet werden sollen.

Kriterien1    Erforderlich. Die Kriterien in Form einer Zahl, eines Ausdrucks, Zellbezugs oder Texts, mit denen definiert wird, welche Zellen gezählt werden. Kriterien können beispielsweise als 32, ">32", B4, "Äpfel" oder "32" angegeben werden.

Kriterienbereich2;Kriterien2; ...    Optional. Zusätzliche Bereiche und deren zugehörige Kriterien. Es sind bis zu 127 Bereich/Kriterien-Paare zulässig.

Wichtig : Jeder zusätzliche Bereich muss dieselbe Anzahl von Zeilen und Spalten wie das Argument Kriterienbereich1 haben. Die Bereiche müssen nicht direkt nebeneinander liegen."

0
Kommentar von visitar
15.06.2016, 00:53

Sorry:

hab meinen Kommentar (Auszug aus der Excel-Hilfe) löschen wollen weil Du deinen Irrtum schneller gesehen hast als ich antworten konnte.
Leider war die Zeit zum Bearbeiten zu schnell abgelaufen ! Sorry !

Die Formatierung werde ich prüfen und auch mal einen Test mit simplem Text und Zellbezug machen

0
Kommentar von visitar
15.06.2016, 01:11

Versuch mit neuer Tabelle:
=ZÄHLENWENNS($J$5:$J$21;">0";$J$5:$J$21;"<2")
ergibt ein fehlerloses Ergebnis.

=ZÄHLENWENNS($J$5:$J$21;M5)
(M5 ist ein Zellbezug) ergibt ein fehlerloses Ergebnis

=ZÄHLENWENNS($J$5:$J$21;>M5)
wird jedoch als fehlerhafte Formel zurückgewiesen

EXCEL nimmt bei Zellbezügen die Vergleichsoperatoren "<" ">" "=" scheinbar nicht an.

Jetzt  wäre ein WORKAROUND hilfreich.

0

Was möchtest Du wissen?