Excel namen rausschreiben per 0/1?

...komplette Frage anzeigen

5 Antworten

Angenommen in Spalte A stehen Deine Namen und in Spalte B steht 1 oder 0 (als Zahl), dann schreibe z.B. in D1 diese Formel und kopiere sie runter, soweit wie nötig:

{=WENNFEHLER(INDEX($A$1:$A$1000;KKLEINSTE(WENN($B$1:$B$1000=1;ZEILE($B$1:$B$1000));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?


Danke fürs

0

Pivot Tabelle wäre eine Variante, aber nicht unbedingt ideal wenn die Daten noch weiter verarbeitet werden sollen. 

Eine Wenn-Formel löst Dein Problem. Siehe Lösung in Grafik

 - (Computer, PC, Mathematik)

das funktioniert nie sauber, wie man schon am ergebnis sieht.

Bei automatischer Übernahme in eine neue Liste würden wie hier zu sehen, immer lücken entstehen. man müsste händisch nacharbeiten und damit sind nachträglichere änderungen kaum möglich

oubyi zeigt die richtige lösung

0

Dies müsste möglich sein in dem Du in der Zelle in der der Name stehen soll einen Befehl anwendet der nach einer 1 oder 0 in der entsprechenden anderen Zelle sucht und somit einsortiert oder nicht.
ZB. WENN([Zelle1]=1;[Zelle 1];" ")
So ähnlich.

Am einfachsten ist es per vba lösen: mit einer for-schleife alle namem durchgehen, per if-bedingung prüfen, ob zelle nebendran eine 1 hat, wenn ja - kopieren.

Das "einfachste" ist das imho NICHT!

1
@Oubyi

es ist nicht nur nicht am einfachsten, spätestens seit der Formatänderung mit den 2007er Versionen sind in der Geschäftswelt Makro Dateien noch schwieriger geworden. Natürlich innerhalb eines Bereiches kann man damit viel machen. In Kontakt mit anderen verbreiten aber *.xlsm Dateien irgendwas zwischen Verwirrung und Panik. Daher sollte man VBA auf Anwendungen beschränken wo es unumgänglich ist.

0

Was möchtest Du wissen?