Excel mit Befehl WENN Zeilen löschen/ausfüllen?

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Löschen im eigentlichen Sinne geht, wie schon genann wurde, mit Formeln nicht.

Wenn ich die Frage richtig verstehe, soll aber die Berechnung von einem vorgegebenen Wert für den Zeitraum abhängig sein. Das geht dann schon mit Wenn.

Um die Formel konkret zu nennen, müsstest Du allerdings noch was zu Deiner verwendeten Berechnung sagen.

Als konstruiertes Beispiel: A1 ist die Anzahl Jahre, B1 ein Anfangsbetrag
ab Zeile B2 - B60

=WENN(ZEILE(B2)<=A$1;B1*1,1;"")

[die Berechnung macht natürlich keinen Sinn, nur als Demo]

Du müsstest die WENN-Funktion in jede Zelle schreiben, die an die Bedingung geknüpft werden soll.

=WENN(A1>30;"Mein Text";"")

Dadurch werden die Zellen zwar nicht gelöscht, aber deren Inhalt variabel gestaltet.

Das geht mit normalen Formeln nicht; dafür wird VBA benötigt

Was möchtest Du wissen?