Excel, mehrere Spaltenwerte in Tabelle müssen stimmen um anderen Wert in Zeile auszugeben?

... komplette Frage anzeigen

3 Antworten

Falls die Daten in den Spalten A:C stehen und das gesuchte Auto in D1, das gesuchte Jahr in E1, verwendest du folgende Formel:

=INDEX(C1:C99;VERGLEICH(D1&E1;A1:A99&B1:B99;0))

Diese Formel als Matrixformel abschließen (mit Strg+Shift+Enter, dabei werden geschweifte Klammern {} erzeugt). Die Bezüge natürlich vorher anpassen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
21.06.2016, 16:09

DH!
Ich glaube ich war diesmal 20 Sekunden schneller

1

Angenommen In E1 steht BMW und in F1 steht 2005. Der Suchbereich ist A1:C10, dann diese Formel:

{=INDEX(C1:C10;VERGLEICH(E1&F1;A1:A10&B1:B10;0))}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?

P.S.: Bekommt das jemand ohne Matrix-Formel hin? Ich meine das geht auch irgendwie, komme aber nicht drauf.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
21.06.2016, 16:09

DH, fast zeitgleich.

Wenn es eine Kombination von Auto und Jahr nur einmal gibt, dann würde auch

=SUMMENPRODUKT((A1:A99=E1)*(B1:B99=F1)*(C1:C99))

funktionieren. Wobei das auch wieder eine verkappte Matrixformel ist.

1
Kommentar von Jackie251
21.06.2016, 16:16

Ohne Matrix/hilfszeilen hätte ich grad keine Idee.

Ich persönlich nutze aufgrund der Fehleranfälligkeit jedoch nie den Vergleich mit & sondern immer WENN. Natürlich ist das bei genauer Übereinstimmung egal, da dann keine Fehler auftreten, aber ob man beim nächstens Bereichsverweis dran denkt :-) ^^

1

Da du uns ja keinerlei infos zum Aufbau denes Sverweis gibst, musst du sinngemäß folgendes umsetzen

=Sverweis(Jahr;Wenn(A1:A3=Auto;A2:C4);3)

das ganze mit STRG+Shift + Enter abschließen

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?