Excel/ Makro automatisch Zelle einfügen?

3 Antworten

willst Du es rückwirkend in der Tabelle einfügen oder sollen auch neue Einträge geprüft werden? Als einmalige Aktion ist recht simpel machbar. Per Makro etwas fragwürdig fände ich eine laufene Überwachung der Einträge, um dann nur zwei Zeilen einzufügen.

Vielleicht eine Alternative: Bedingte Formatierung und den ersten Eintrag des Jahres hervorheben: Dazu die Spalte D ab D2 markieren. Neue bedingte Formatierung -> Formel zur Ermittlung der Formatierung wählen und dort:
=JAHR(D2)>JAHR(D1)

Einmalmakro:

Sub zeiledazu()
For i = Cells(Rows.Count, 4).End(xlUp).Row To 2 Step -1
If Year(Cells(i, 4)) > Year(Cells(i - 1, 4)) Then
Rows(i).Insert
Rows(i).Insert
End If
Next
End Sub

Ich verstehe das jetzt nicht ganz.

Du hast also eine Tabelle wo du in Spalte D immer Datümer eingetragen hast und da sollen bei Jahreswechsel jetzt zwei Leerzeilen eingefügt werden?

Ich könnte jetzt ja ganz doof sagen dann nimm doch einfach für das nächste Datum, wenn es das nächste Jahr ist die dritte Zeile weiter unten dann hast du zwei Leerzeilen.

Doch ich denke das dort wohl was anderes hintersteckt was du nicht erwähnt hast oder? Sind da die Zeilen ausgeblendet oder wird das Datum irgendwie anders als händisch eingetragen? Irgendwas fehlt hier um für dich eine Lösung zu finden?

Das sollte - ohne Makro - so klappen:
Nimm eine ungenutzte Spalte - im Beispiel Spalte E - und schreibe in E2 diese Formel:
=WENN(JAHR(D2)>JAHR(D1);)und kopiere sie nach unten, soweit wie nötig.
Jetzt Spalte E komplett markieren und F5 drücken (Gehe zu).
Dort: Inhalte.../ Formeln --> Häkchen nur bei ZAHLEN stehen lassen/ OK
Jetzt Rechtsklick auf eine der markierten Nullen:
Zellen einfügen/ Ganze Zeile/ OK
Jetzt sollte eine Zeile eingefügt sein, wie gewollt.
Um noch mehr Zeilen einzufügen, das Ganze ab :
"Jetzt Spalte E komplett markieren"
wiederholen.

Klappt es?

Nur bedingt, ich wollte ja, dass sich die Zeilen automatisch einfügen und nicht durch einzelnes anklicken, wollte mir ja dadurch die Zeit sparen. Aber danke trotzdem.

0
@MrDuncan

Du brauchst dazu auch keine Zellen einzeln anzuklicken. Wie beschrieben, geht das "in einem Abwasch". Ein Makro zu schreiben dauert da länger. Wenn Du allerdings täglich oder stündlich neue Jahresdaten anhängst, wäre wohl doch ein Makro effektiver.
Stell dann vielleicht noch einmal eine neu Frage und füge dort diesen Thread als Link ein.

0

Was möchtest Du wissen?