Excel logische Formel für Farbtonwinkel generieren?

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Noch eine Alternative zu den Lösungen von Funfroc und Imperfektion, ohne WENN:

=ARCTAN(b/a)-(a<0)*180+(b<0)*360

Für a und b natürlich die Werte oder Bezüge einsetzen.

Die Terme a<0 und b<0 sind einfach Wahrheitswerte, die 0 (falsch) oder 1 (wahr) sind, und mit denen kann man normal rechnen. Wenn beide Werte negativ sind, addieren sich die -180 und +360 zu den geforderten +180.

40

DH! ich wusste, es geht noch kürzer, aber nicht mehr, wie!

ich nehme allerdings an, dass die Klammer erst am Ende geschlossen werden muß, da bin ich mir aber nicht sicher.

im Übrigen siehe auch Kommentar in meiner AW!

1
=WENN(UND(A1<0;B15<0);(b1/a1)+180;WENN(A1<0;(b1/a1)-180;WENN(B1<0;(b1/a1)+360;(b1/a1))))

So, deine Formel sonst kenne ich nicht! Mit dieser Formel hier kannst du aber deine 3 Fälle abdecken!

Was soll passieren wenn beide Zahlen positiv sind?


Grüße,


iMPerFekTioN

1

Wenn beide positiv sind, soll nichts passieren mit dem Wert

LG

1
40
@LaNat

mein Mathematisches Wissen hält sich leider in engen Grenzen, hab halt ein paar praktische Erfahrungen und vage Erinnrungen an die Ausbildung (als Chemie-Ingenieur und später weiter zum Dipl.Chem, also anderer Schwerpunkt), u.a. den Merksatz: Der Arctan ist der Bogen zum Tangens des Ausdrucks

Was die Genauigkeit angeht: bei 1 ist die xl-Genauigkeit i'wo zwischen 10^-15 und 10^-16 (da im Dualsystem: 2^-50, habs ausprobiert, wobei bei 1+2^-48 die Grenze liegt, aber andererseits bei 1-2^-50, kann mir die Diskrepanz noch nicht erklären)

Bei 2^-24 (10^-7...10^-8) sollte das geometrische Mittel liegen. mehr weiß ich dazu auch nicht.

1

Hallo,

wenn ich dich richtig verstehe, so:

=wenn(und(a<0;b<0);(b/a)+180;wenn(a<0;(b/a)-180;wenn(b<0;(b/a)+360;b/a)))

LG, Chris

1

Ja! Danke schön!!

LG

2

Excel 2010 - Mit ganzer Zahl weiter rechnen

Hallo,

Wie kann ich dafür Sorgen, das Exel bei einer Formel nicht mit Kommazahlen rechnet sondern dem ganzen Wert. Also ich habe eine Rechnung in z.B. Zelle A1: 275cm / 17,5 = 15,71

In der Zelle A3 habe ich dann Die Formel: 275cm / A1 = XX

Jetzt möchte ich aber nicht das Excel 275cm / 15,71cm rechnen, weil dann würde da ja wieder 17,5 rauskommen, sondern mit der aufgrundetet Zahl. Also: 275cm / 16 = 17,2cm

Ich kann zwar Einstlelen das mir die Zahl 16 angezeigt wird, allerdings Rechnet Excel weiterhin mit 15,71 und nicht mit 16. Wie kann ich das Einstellen?

Gruß, Jacksen

...zur Frage

Excel Formel aktualisiert sich nicht

Hallo,

ich habe eine Excel Tabelle, wo ich bestimmte Wörter zähle.

Die Formel ist : =ZÄHLENWENN(C5:AG5;"EU")

er berechnet mir auch die korrekte Anzahl - änder ich aber einen Wert, aktualisiert die Formel den Wert ERST, wenn ich die Formel noch mal anklicke und mir grünem Häkchen bestätige.

Was ist da los ? :) das ist bei allen Formeln so ... ist das ne Einstellungssache in Excel ?

...zur Frage

Arctan auf Excel will nicht so.

ich habe auf Excel versucht, folgende Aufgabe zu berechnen:

http://www.leifiphysik.de/themenbereiche/quantenobjekt-elektron/versuche#lightbox=/themenbereiche/quantenobjekt-elektron/lb/elektronenbeugung-loesung-1

Dabei kamen bei mir komplett andere Werte heraus: (ARCTAN(1,75/13))/2=0,669

Woran liegt das, und wie kann ich Excel dazu bringen, richtig zu rechnen?

Danke für eure Antworten.

...zur Frage

Excel: Aus Alter und gesamten Verbrauch den Durschnittsverbrauch pro Jahr berechnen?

Hallo,

ich benötige eine Formel mit der ich in Excel aus dem Alter des Autos (angegeben in Monaten) und dem insgesamten Verbrauch den Jahresverbrauch heraus rechnen kann.

Gibt es da eine Formel, bzw. eine Möglichkeit das zu rechnen?

...zur Frage

Word Dokument aus Excel generieren?

Hallo!

Ist es möglich, z.B. in ein fertiges Word Dokument wie zum Beispiel eine Blanko Rechnung, Excel automatisch in dieses Dokument die ganzen Daten eintragen zu lassen? Wenn ja mit welcher Formel?

...zur Frage

Was ist an meiner Excel Formel Falsch (besseres Bild)?

Es kommt immer #wert! raus

...zur Frage

Was möchtest Du wissen?