Excel: Liste mit Wörtern durch Komma trennen

...komplette Frage anzeigen

2 Antworten

  • Kopieren
  • Einfügen (transponiert)
  • Datei / Speichern unter... / xxx.csv
  • Mit Texteditor öffnen
  • Ersetze ";" durch ", "
  • Zeile kopieren
  • In Excel einfügen
  • Unter Excelformat speichern
Suboptimierer 08.10.2013, 16:59

Du kannst dir auch folgendes Makro in deiner Mappe anlegen:

Public Function Verketten2(rBereich As Range, sTrennzeichen As String)
  Verketten2 = ""
  For Each rZelle In rBereich
    If Verketten2 <> "" Then _
      Verketten2 = Verketten2 & sTrennzeichen
    Verketten2 = Verketten2 & CStr(rZelle.Value)
  Next
End Function

Beispielaufruf:

=Verketten2(C4:E4; ", ")
0
Suboptimierer 08.10.2013, 17:08

Noch eine Möglichkeit. Wenn in B4 sagen wir "Bier" steht, dann schreibe in C4 die Formel:

=WENN(C3="";"";C3&", ") & B4

und ziehe die Formel bis zur Zeile mit dem letzten Wert. Dort steht dann die Verkettete Zeichenfolge in C[letzte Zeile]

0

Was möchtest Du wissen?