Excel Kalkulator

...komplette Frage anzeigen

1 Antwort

Hallo Ikiou,

das ist in Excel eigentlich ganz einfach zu programmieren.

Du musst nur zu jeder Kategorie die möglichen Arten und deren Punktezahl wissen.
Beispiel:

Kategorie   Art                      Punkte 
Schiff:     Leichter Transporter       15  
            Kolonistentransporter      65  
            B20 Schockschiff         1862  

Rüstung:    Thermorüstung            1034  
            Sintflutrüstung          2534  
            Methanoidenrüstung          0  

Blaster:    Standard Ionenblaster      46  
            Verbesserter Ionenblaster  82  
    usw.  

How?
Tabellenblatt Liste:
A1: Kategorie, B1: Art, C1: Punkte, D1: Index

B2:B11 alle bekannten Schiffsarten eintragen
C2:C11 alle zu den Schiffsarten gehörenden Punktezahlen eintragen
D2: nichts eintragen !

Tabellenblatt Kalkulator:
A1: Kategorie, B1: Art, C1: Punkte
A4: Das Wort "Schiff" eintragen

Entwicklertools
Steuerelemente / Einfügen
Formularsteuerelemente / Kombinationsfeld
mit der Maustaste die Zelle B4 markieren (von der li. Oberen Ecke zu der re. unteren Ecke aufziehen)
Steuerelement mit RMT anklicken, Steuerelement formatieren
Eingabebereich: alle Arten zu einer Kategorie markieren (z.B.: Liste!$B$2:$B$11)
Zellverknüpfung: eine frei Zelle rechts neben der Punktezahl der ersten Art selektieren (z.B.: Liste!$D$2)

rechts neben dem Steuerelement in Zelle C4 diese Funktion eingeben: =INDEX(Liste!C2:C11;Liste!D2)

so mit allen Arten zu jeder Kategorie verfahren

danach noch in Zelle C20: =SUMME(C2:C19) eingeben
FERTIG ist der Kalkulator!

Gruß Distel

Vielen Dank Habs hingekriegt

0

Was möchtest Du wissen?