Excel: Ist die Funktion 'Zählenwenn' mit zwei Bedingungen möglich?

...komplette Frage anzeigen

3 Antworten

Hi, probier es doch mal mit der Formel Summenprodukt! =SUMMENPRODUKT((A1:A5="Lieferant")*(B1:B5="Produkt");(C1:C5))

Wobei "Lieferant" durch den jeweiligen Namen der Liste zu ersetzen ist. Das gleiche gilt für "Produkt". Der Zellbereich hinter dem Semikolon steht dann für die Geldbeträge und/oder die Anzahl.

Diese Formel verknüfpt demnach mehrere Bedingungen miteinander, um dann ein Ergebnis zu berechnen.

Viel Spaß mit der Formel.

Da ich eine knappen Liefertermin gesetzt bekommen hatte, habe ich es nun mit den Pivot-Tabellen gelöst. Ich werde es mir in einer ruhigen Minute gerne mal anschauen - die nächste Analyse kommt bestimmt. Darum DH und Danke trotzdem!

0

Probier sowas mit einer Pivottabelle!

Nach Auswahl der Daten entsteht eine leere Pivottabelle, dort ziehst Du die Daten als Zeilen- und Spaltenfelder hinein und in der Mitte die relevanten Summen.

Ich habe es fast befürchtet. Aber das klappt recht gut. Damit kann man weitermachen.

0
@markus021169

Keine Angst, sobald man sich ein wenig hineingearbeitet hat, liebt man Pivottabellen =)

0
@aleph

Pivottabellen sind eine feine Sache. Da es aber ehrlicherweise noch ein paar Bedingungen mehr sind (und ich dazu mehrere Pivot's brauche), hatte ich auf eine schlankere Lösung gehofft. Aber so geht es über Umwege auch.

Die Frage hatte ich extra auf zwei Bedingungen reduziert, um es nicht zu verkomplizieren.

0

also hier ist eine egelgante lösung.

du kannst zählenwenn verwenden musst aber eine code generieren für die lieferant und produkt.

hab mal eine mustertabelle hochgeladen.

http://rapidshare.de/files/40810047/zaehlenwenn.xls.html

Sicher die professionellste Lösung, aber ich bin angehalten, auf Makros möglichst zu verzichten. Ich schaue es mir zum Lernen trotzdem gerne an. Danke für Deine Mühe!

0

Was möchtest Du wissen?