Wie kann ich in Excel immer auf 0 oder 5 aufrunden?

...komplette Frage anzeigen

2 Antworten

=A1+4-REST(A1+4;5)
Suboptimierer 04.08.2015, 16:28

Was auch geht (gerade gefunden): 

=OBERGRENZE(A1;5)
3

Probiers mal mit

=AUFRUNDEN(A1/5;0)*5

AppDev04 04.08.2015, 14:15

Danke, hat funktioniert.

0
Iamiam 04.08.2015, 15:31
@AppDev04

so mach ichs auch immer, obwohl xl dafür die Formel Vrunden() vorgesehen hat, die man sich dann extra merken muss und neben den vielen anderen nur bei häufigerem Gebrauch zusätzlich merken kann.

2
Suboptimierer 04.08.2015, 16:25
@Iamiam

Ich habe es mit VRUNDEN probiert, aber nicht geschafft. Wie lautet denn die Formel mit VRUNDEN?

0
Iamiam 05.08.2015, 10:18
@Suboptimierer

=VRUNDEN(positiveZahl;5)

aber genau das ist die Krux: VRunden geht nicht für negative Zahlen, vermutlich hast Du's damit probiert, und der ähnlichen Funktionen sinds so viele...

Ober-/Untergrenze() und Auf-/Abrunden() verhalten sich unterschiedlich bei negativen Zahlen, Runden()tut so, als gäbe es kein Vorzeichen (. In Lotus-123 gabs mal die Funktion @Schneide(), die war wenigstens diesbezüglich logisch benannt, aber m.W. nur für Dezimalstellen.

Ich musste tief in meinem Archiv wühlen, um das wieder auszugraben.

0
Suboptimierer 05.08.2015, 10:34
@Iamiam

VRUNDEN(Zelle;5) liefert bei mir:

 A  B
0 0
1 0
2 0
3 5
4 5
5 5
6 5
7 5
8 10
9 10
10 10

Ich habe es so verstanden, dass das Ziel ist:

 A  B
0 0
1 5
2 5
3 5
4 5
5 5
6 10
7 10
8 10
9 10
10 10
0
Suboptimierer 05.08.2015, 10:37
@Iamiam
=VRUNDEN(Zelle+2,49999;5)

würde gehen. Das ist aber ungenau mit 2,49999.

1
Iamiam 05.08.2015, 11:28
@Suboptimierer

Hast recht, man kann die Runden-Formeln wirklich nicht im Kopf behalten, muss jedes Detail nachschlagen (ich jedenfalls). und hab dabei die Fragestellung aus den Augen verloren.

Wenn wir gerade dabei sind, und damit du wenigstens etwas von dieser Diskussion profitieren kannst:

xl hat keine Funktion, um auf zB 3 Zählstellen Genauigkeit zu runden, unabhängig von der Größe (zB Messgenauigkeit unterschiedlicher Größen, Blutwerte etc) Da hab ich mir mal diese Formel einfallen lassen, die ich hier vor längerem schon mal gebracht habe, die aber durchaus etwas Verbreitung finden könnte (ich beanspruche kein Copyright). In A1 Zahl, in B1 Zählstellen:

=+RUNDEN(A1;$B$1-1-GANZZAHL(LOG(ABS(A1))))

anstatt Runden natürlich ggf auch die anderen Formeln, hab ich aber nicht mehr getestet, gibt bei unganzzahligen Teilern sicher Probleme mit log().

1
Suboptimierer 05.08.2015, 11:34
@Iamiam

Hmm, sieht aus, als hätte sich da jemand richtig Gedanken gemacht und es ist eine gute Ergänzung für diese Frage. 

Ich weiß aber nicht ganz genau, wann man das benötigt. Was meinst du mit "3 Zählstellen Genauigkeit"? Auch der mathematische Hintergrund (Herleitung) wäre interessant.

Ein Beispiel würde deinen ergänzenden Post "abrunden". :D

1
Iamiam 07.08.2015, 15:47
@Iamiam

ach so, Herleitung:

A1 Zahl, in B1 Zählstellen:

=+RUNDEN(A1;$B$1-1-GANZZAHL(LOG(ABS(A1))))

=Runden(A1;n) ist eh klar

n:

Zahlen zwischen 1 und 10 haben den log(Zahl) = 0...1

Zahlen zwischen 10 und 100 haben den log(Zahl) = 1...10

Zahlen zwischen 0,1 und 1 haben den log(Zahl) = -1...0 usw.

Die Größenordnung ist also durch die Ganzzahl definiert, die Mantisse definiert nur die genaue (genäherte) Zahl und braucht deshalb fürs Runden auf eine Größenordnung keine Rolle zu spielen

Für Aufrunden müsste man wahrscheinlich die entsprechende Fkt nehmen und bei 5 wahrscheinlich auch erst mit 2  multiplizieren und dann wieder dividieren, hab das jetzt nicht mehr ausgeführt.

0

Was möchtest Du wissen?