Excel Hilfe Stundenzettel Formel?

Excel  - (Excel, Formel, Zeiterfassung)

5 Antworten

Nach kurzem Herumtüfteln kam ich auf folgende Lösung

=WENN(C3="x";(B3-A3)-0,0205;(B3-A3))

Zur Erklärung:

=WENN(C3="x";

Überprüft ob das Feld C3 ein x beinhaltet. Bei dir wäre dies F9

(B3-A3)

Das voneinander Abziehen ohne den 30 Minuten Abzug.

-0,0205

Das Abziehen des Abzuges von 0:30. Formatierte Zahlenwerte wie bspw. 12:46 haben immer irgendeine Entsprechung als normale Zahl. 0:30 entspricht dabei 0,02 (12:46 würde 0,53 entsprechen). Weil Excel (vermutlich verursacht durch eine Rundung-Funktion) jenachdem nur einen Abzug von 29 Minuten anzeigt, habe ich als kleinen Trick 0,0205 abgezogen. Der Effekt davon ist einfach nur das es soweit die korrekte Zahl anzeigt.

 - (Excel, Formel, Zeiterfassung)

Dein Bild und die Gleichung passen in den Spalten nicht zusammen, und beides passt nicht zu den Spalten des Fragestellers.

B3-A3 ist nun sowohl in DANN als auch im SONST Bereich enthalten.
Warum dann nicht gleich

=B3-A3-WENN(C3="x";0,0205)

Liest sich auch leichter: Endzeit - Anfangszeit - , falls Pause enthalten ist...

Zudem besteht der "Trick" - wie ihn die Mathematik der 5/6 Klasse lehrt - darin periodische Brüche als Brüche zu berechnen und nicht auf Dezimalzahlen zu runden.
Warum also 0,0205 war 29 Minuten und 31 Sekunden sind? Das wird in der Summe der Wochenarbeitszeiten zwangsweise zu Rundungsfehler führen.
Besser ist man setzt statt 0,0205 den korrekten Wert 1/48 ein.


=B3-A3-WENN(C3="x";1/48)



Und auf die Wennfunktion kann man dann auch gleich verzichten, siehe mein Beispiel.

0
@Jackie251

Ob auf die Wenn-Funktion verzichtet werden kann in Hinblick auf Lesbarkeit ist fraglich. Ob die Zellenbezeichnungen soweit übereinstimmen ist unerheblich. Hinweise darauf ob Themen während einer bestimmten Schulklasse drin vorkommen sind eher kontraproduktiv, da sich die Lehrpläne von Land zu Land unterscheiden können, und sich Lehrer nicht unbedingt daran halten.

Ansonsten:
Nachdem ich meine Tabelle dezent erweitert habe, ist mir durchaus der Rundungsfehler bei meiner Variante aufgefallen. Wie fälchlicherweise von mir angenommen arbeitet Excel nicht mit 0,02 sondern mit "0,0208333333333333". Keine Ahnung ob Excel im Hintergrund genauer rechnet, falls nein, würden Rundungsfehler erst sehr spät auftreten (Ein Test mit 500.000 Datensätzen in Excel hat bspw. noch keine Rundungsfehler ergeben).

Zusammenfassend lässt sich sagen:
Entweder man verwendet die Variante mit /48 oder verwendet ein Hilfs-Feld. (Als großer Fan von Hilfs-Feldern würde ich natürlich zum Hilfsfeld raten. Lässt sich später besser anpassen.)

1
@Megalomon

xl rechnet auf 15 Stellen genau, möglicherweise noch um den dualen Faktor 2, 4 oder 8 besser, aber nicht auf 16 Stellen genau.

Da die Sekunde ~10^-5 Tage ist (=1/(24*60*60), macht sich ein Sekunden-Rundungsfehler erst ab 10^-10 *Zellenzahl bemerkbar.

0

Mach dir doch eine Hilfszelle.  z.B. in G1 "00:30"

Dann beziehst du dich einfach in der Wenn Formel auf G1

Geh mal in den PlayStore. Ich habe für meine Arbeitszeit dort eine App gefunden, mit der ich die kommen/gehen usw. Zeiten verwalten kann. Die Auswertung erfolgt über ein Excel-Sheet. 

Installier dir das mal und seh es dir an, wenn du eine Auswertung gefahren hast. Da kannst du alle Formeln sehen. Dürfte dein Problem lösen.

dafür reicht diese Formel aus

=E9-D9-(F9="x")/48

Warum trägst statt eines x nicht direkt die Minuten ein?

Weil x immer 30 Minuten sind und es einfach in meinen Augen schneller und komfortabler ist da schnell ein x reinzuschreiben. Gibt auch Tage wo ich nur 4 Stunden auf Arbeit bin und keine Pause mache dann kommt kein x rein und er rechnet nur die Arbeitszeit

0

Was möchtest Du wissen?