Excel Hilfe gesucht - Wenn mit SVerweis verknüpft

...komplette Frage anzeigen

4 Antworten

Ist in der Aufgabenstellung ausdrücklich von einer Formel die Rede? Wenn nicht, mach Folgendes:

Markiere Deine lange Liste, alles, was da drin steht, und (für ggf. späteresnoch ein paar Spalten nach rechts.)
Geh auf das Icon SORTIEREN UND FILTERN, dann auf FILTERN. In der obersten Zeile des Bereichs erscheinen Dir nun Knöpfe. Geh auf den in der Namensspalte und klicke den Haken im Kästchen "Alle Anzeigen" weg. Wähle in der dann verbleibenden Liste den gesuchten Namen aus. Das Gleiche mit den Vornamen.
Der gesuchte Name erscheint Dir nun mit allen Daten als einzige Zeile, rechts davon kannst Du nun in die erste freie Spalte (sollte auch einen Knopf haben) Deinen Eintrag machen.
Danach gehst Du in beiden Spalten wieder auf "alle anzeigen" und kannst dann der Reihe nach alle Namen durcharbeiten.

Am Schluss machst Du das gleiche mit der Spalte ...versenden und kannst so eine Liste aller Namen, die noch eingeladen werden müssen, erhalten.

Danke für deine Antwort. Jedoch würde ich Jahre brauchen, bis ich die 7000 Namen auf diese Weise gesucht und gefunden hätte :-) copy und paste ist da mit einer Formel einfacher.Trotzdem danke!

0

Neue Antwort wg. Screenshots:
Schau Dir die beiden Screenshots an, müsste sich eigentlich von selber erklären.
Ich habe jetzt meine Blätter auch Kladde1 und Kladde2 genannt. Formel in Kladde2, C1 ist jetzt:
=WENN(NICHT(ISTNV(VERGLEICH(A1;Kladde1!A:A;0)=VERGLEICH(B1;Kladde1!B:B;0)));WENN((VERGLEICH(A1;Kladde1!A:A;0)=VERGLEICH(B1;Kladde1!B:B;0));"Einladung muss noch verschickt werden";"Einladung ist bereits verschickt");"Einladung ist bereits verschickt")
Wie gesagt dass die VEGLEICH=VERGLEICH Gleichung doppelt vorkommt, hat seinen Grund. Ich hoffe jetzt ist es klarer geworden?!

Kladde1 - (Excel, Sverweis, WennUnd) Kladde2 - (Excel, Sverweis, WennUnd)

Vielen Dank für deine Mühe! Ich habe es genauso übernommen und ich weiß einfach nicht woran es liegen kann, dass er mir nicht die jeweils richtigen Aussagen ausspuckt. Er meckert zwar nicht und zeigt untersch. Erbenisse, die aber leider nicht korrekt sind.... ich habe diese Formel nun angewandt (um es einfach zu halten, habe ich alles in ein Blatt kopiert): =WENN(SUMMENPRODUKT(N($A$2:$A$2794&"#"&$B$2:$B$2794=E2&"#"&F2));"Einladung muss noch verschickt werden";"Einladung ist bereits verschickt")

Das hat tatsächlich super funktioniert, was hältst du davon??

0
@NeugierigIII

OK!
Ich gebe mich geschlagen. (;o) DAS ist einfacher und damit auch besser als meine Lösung (Die bei mir allerdings funktioniert!?).
Ich hatte so etwas zwar auch erwogen, dachte aber es würde nicht klappen.
Also habe ich mal wieder was gelernt.
DANKE.

0

Am einfachsten wäre es mit Hilfsspalten, in denen Du Vorname und Name verkettest, aber das möchtest Du ja ungerne, was ich verstehe.
Dann vlt. so:
In Tabelle1 Spalte A die Vornamen und in B die Nachnamen, Deiner "ersten Kladde".
In A1 (von Tabelle 2 oder sonstwo) der erste gesuchte Vorname Deiner "2.Kladde", und in B1 der entsprechende Nachname.
Fomel in C1:
=WENN(NICHT(ISTNV(VERGLEICH(A1;Tabelle1!A:A;0)=VERGLEICH(B1;Tabelle1!B:B;0)));WENN((VERGLEICH(A1;Tabelle1!A:A;0)=VERGLEICH(B1;Tabelle1!B:B;0));"Einladung muss noch verschickt werden";"Einladung ist bereits verschickt");"Einladung ist bereits verschickt")
Das sieht wilder aus, als es ist.
Im Moment (kurz vor Mitternacht) fällt mir nichts einfacheres ein, aber funktionieren müsste es.
Teste mal ausgiebig.

hallo Oubyi,

erst einmal danke für deine Hilfe. Die Formel klingt gut. Da ich leider nicht so tief im Excelthema bin, hat es bei mir nicht wie erwartet geklappt. Kannst du ein kurzes Beispiel anführen (zur Veranschaulichung)? Ich habe da z.b. das Problem, dass ich aus der Formel nicht erkennen kann, auf welchen Wert (in welcher Tabelle) du dich beziehst. In dieser Formel sehe ich immer nur Tabelle 1. Wenn ich das auf meine 2 Kladden anwende, mache ich theoretisch 2 mal das Gleiche in der Formel. Vielleicht habe ich es einfach noch nicht verstanden. Hast du Zeit und Lust zu einer kurzen Veranschaulichung am Praxisbeispiel? Danke im Voraus!

0
@NeugierigIII

Das ist schon richtig, dass in der Formel zweimal das gleicht "passiert".
Ich frage erst ab, ob:
(VERGLEICH(A1;Tabelle1!A:A;0)=VERGLEICH(B1;Tabelle1!B:B)
einen #NV-Fehler ergibt, und erst wenn NICHT, dann werte ich diese Gleichung aus.
Aber ich schreibe Dir nochmal eine neue Antwort mit Screenshots (in Kommentaren geht das hier leider nicht).

0

funktioniert leider nur bei einmaligem Auftreten des Schreibnamens! Dafür gehts dann auch kürzer:

=A1&", "&B1&" "&WENN($B$1=INDIREKT("Tabelle1!B"&VERGLEICH($A$1;A:A;0));"Einladung muss noch verschickt werden";"Einladung ist bereits verschickt")

Mit Vergleich(..;..;1) müsste es dann vom anderen Ende her möglich sein, in einer zweiten Zelle drunter eine zweite Nennung zu identifizieren, aber das gibt dann zwei sich widersprechende Meldungen, was verwirrend ist.

Unbefriedigend bleibts, auch wenn mir noch einige sehr komplizierte Vielleicht-Lösungsmöglichkeiten einfallen , für die ich jetzt aber keine Zeit mehr habe! Aber keine mehr als zwei Nennungen. Vielleicht hilft noch das:

http://www.excelformeln.de/formeln.html?welcher=194

0
@Iamiam

Habe ich Oubyi vorgeschlagen (um es hier zu verdeutlichen, habe ich erstmal alles in ein Blatt kopiert, funktioniert auch Blattübergreifend): =WENN(SUMMENPRODUKT(N($A$2:$A$2794&"#"&$B$2:$B$2794=E2&"#"&F2));"Einladung muss noch verschickt werden";"Einladung ist bereits verschickt")

Was ist damit? Es hat geklappt.

0

Hallo,

die formel müsste ca. so gehen:

=wenn(istnv(sverweis(Suchkriterium;Matrix; Spaltenindex;Falsch));"Einladung bereits verschickt";"Einladung noch verschicken")

Gruß J

Der Knackpunkt bei der Fragestellung ist doch, dass sowohl Vorname als auch Nachname, die in ZWEI Spalten stehen, stimmen müssen! Es gibt also ZWEI Suchkriterien.

0

Was möchtest Du wissen?