Excel Hilfe bei zellbezug, könnt ihr mir helfen?

...komplette Frage anzeigen

3 Antworten

Hallo du,

wenn ich dich richtig verstanden habe, hast du hier ein Problem welches eigentlich kein Problem ist.

Excel sowie auch LibreOffice haben eben diese "Syntax" das wenn man eine Formel 1. Feld runter zieht, es in der Formel auch den nächsten darunter liegenden Wert der vorherigen angegebenen Zelle nimmt.

Wenn du dieses Problemchen umgehen willst, musst du dir eine Hilfsspalte anlegen, in der du deine Suchergebnisse verwendest.

So z.B.

Da du ja immer in gleichen Abständen arbeitest (Sprich, Abstände von 14 Zellen!)

Deshalb schreibst du in Abständen von 14 Zellen in die Spalte C z.B. bei C26 = B6 und C38 = B7 ....

Die Formel kannst du dann ja auch runter ziehen.
Formel in A26:

=SVERWEIS(C26;[$Deine$Matrix];[$Deine$Spalte];0)

Jetzt kannst du auch deine SVERWEIS Formel runter ziehen und es wird dir immer der Wert genommen den du wolltest. Sozusagen eine kleine Hilfsspalte mit "Umlenkung"

Grüße,


iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung

Mein Lösung wäre:

A10: =SVERWEIS(INDIREKT("B"&AUFRUNDEN((ZEILE()-9)/14;0)+4);$D$2:$E$5;2;0)

Teste mal genau.

Aber Ninombres Formel klappt - natürlich - auch und ist direkt runterziehbar (darf natürlich nichts anderes dazwischen stehen).
Meine müsstest Du in die jeweilige Zelle 14 Zeilen weiter einkopieren.

Antwort bewerten Vielen Dank für Deine Bewertung

Probier die Formel mal in A10 einzutragen und dann runterzuziehen:

Den Suchbereich für den SVerweis musst Du noch anpassen:

=WENN(REST(ZEILE(A10);14)=10;SVERWEIS(INDIREKT("B"&AUFRUNDEN(ZEILE(A10)/14;0)+4);K$1:L$4;2;FALSCH);"")

Um nur ein Ergebnis in jede 14. Zeile zu schreiben:
WENN(REST(ZEILE(A10);14)=10

Um die Zeilennummer des Suchbegriffs nur alle 14 Zeilen um eine zu erhöhen:

AUFRUNDEN(ZEILE(A10)/14;0)+4)

+4 weil der erste Suchbegriff nicht in Zeile 1 sondern Zeile 5 steht.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von schmiddi1967
07.10.2016, 11:22

DH! Ninombre

0

Was möchtest Du wissen?