Excel, Gültigkeitsprüfung, ob wert bereits vorhanden?

... komplette Frage anzeigen

5 Antworten

Hab da zwar keine Erfahrung, aber das hört sich so an, als würde die Gültigkeitsprüfung nur auf Wert-Eingaben, aber nicht auf geänderte Formelergebnisse reagieren?

In diesem Fall könnte ein Worksheet_Change-Makro helfen, das die Überprüfung durchführt und Eingaben verhindert

Wenn Du sowas willst, melde Dich IN DIESER ANTWORT. Bin zwar momentan sehr beschäftigt, aber sollte kein Hexenwerk sein.

Die einfachere Lösung wäre freilich ein auffällig formatierter Warnhinweis, der mit einer der genannten Formeln Text liefert, ansonsten nur einen Punkt oder gar nichts.

Der Warnhinweis kann auch die Zeile des untersten Auftretens beinhalten oder auch den Stand des Cursors..

Antwort bewerten Vielen Dank für Deine Bewertung

Nur mal so zu Klarstellung:

Zur Feststellung eines dreifachen Eintrages kannst Du

eine Hilfsspalte (im Bilschirmfoto Spalte B) mit der Formel von Sternenfleit "=WENN(ZÄHLENWENN(A:A;A1)>3;"zuviel";"3 oder weniger")

ODER/UND

die "Bedingte Formatierung" mit der Formel von PWolff benutzen:: =ZÄHLENWENN(A:A;A1)>3

Beide Varianten sind im Bildschirmfoto zu erkennen.

Gruß aus Berlin


Antwort bewerten Vielen Dank für Deine Bewertung

=zählenwenn($A:$A;"meinWert")<=3

(3faches Auftreten selbst ist ja auch zulässig)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von jumbo125
13.07.2017, 17:14

da passiert nie etwas, auch wenn ich es öfter als 3mal eingebe

0
Kommentar von jumbo125
13.07.2017, 19:01

T1 t2 usw

0

Hallo,

sollte funktionieren:

=ZÄHLENWENN(A:A;A2)<=3

LG, Chris

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von jumbo125
13.07.2017, 17:13

da passiert nichts. Nie.. egal was ich eingebe

0

=wenn(zählenwenn(a:a;"meinWert")>3;"zuviel";"3 oder weniger")

Wenn auch geprüft werden soll, ob 1 oder 2 mal vorkommt musst Du die Formel erweitern.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Funfroc
13.07.2017, 14:32

sorry, aber ich glaube du hast die Frage gar nicht gelesen...

Es geht um die Datenüberprüfung... die ja genau wie die bedingte Formatierung per se schon WENN-Funktionen darstellt.

0

Was möchtest Du wissen?