Excel Funktion Wenn ein Wert in einer Spalte ist soll eine andere Spalte etwas anzeigen

3 Antworten

Entweder die Variante 1:

=WENN(UND(A7 = ""; A8 = ""; A9 = ""; A10 = ""; A11 = ""; A12 = ""; A13 = ""; A14 = ""; A15 = ""; A16 = ""; A17 = ""; A18 = ""; A19 = ""; A20 = ""; A21 = ""; A22 = ""; A23 = ""; A24 = ""; A25 = ""; A26 = ""; A27 = ""; A28 = ""; A29 = ""; A30 = ""; A31 = ""; A32 = ""; A33 = ""; A34 = ""; A35 = ""; A36 = ""; A37 = ""; A38 = "");"Seite 1/1";"Seite 1/2")

oder wenn es nur um Zahlenwerte geht, geht auch Variante 2:

=WENN(SUMME(A7:A38) = 0; "Seite 1/1"; "Seite 1/2")

Oh, mir ist grad aufgefallen, dass es nur bis A34 geht. Hab mich wohl irgendwo verlesen. Also bei Variante 1 alles, was nach 34 kommt rausschmeißen und bei Variante 2 halt 38 durch 34 ersetzen.

0

So:

=WENN(ANZAHL2(A7:A34)=0;"Seite1/1";"Seite1/2")

Klappt es?

Stimmt, an die Möglichkeit hab ich garnicht gedacht. Das ist wohl die eleganteste Lösung für das Problem.

0
@daCypher

oder noch kürzer, aber auf Kosten der Übersichtlichkeit:
="Seite1/"&WENN(ANZAHL2(A7:A34)=0;1;2)

0

=wenn(summe(a7:a34)=0;"Seite 1/1";"Seite 1/2")

DAS klappt NICHT, wenn in die Zellen Text geschrieben wird.

0

Was möchtest Du wissen?