Excel Funktion die immer auf den nächstkleineren Euro-Betrag (mit 90 Cent) abrundet?

...komplette Frage anzeigen

4 Antworten

Hallo,

so funktioniert es:

=WENN(REST(A1;1)<0,9;ABRUNDEN(A1;0)-0,1;ABRUNDEN(A1;1))

Geht aber bestimmt noch eleganter.

LG, Chris

Funfroc 13.07.2017, 09:34

kurze zusätzliche Frage... soll Komma 90 beibehalten oder abgerundet werden.

Meine Logik sagt 23,90 --> 23,90

Oder soll es so sein 23,90 --> 22,90

1
Suboptimierer 13.07.2017, 09:47
@Funfroc

Danke für den Hinweis. Nun muss ich meine Antwort auch anpassen...

0
=A1+0,9-REST(A1;1)-(0,9-REST(A1;1)>0)
Suboptimierer 13.07.2017, 09:48

Um nicht bereits auf 0,9 gerundete Beträge abzurunden empfiehlt sich ein zusätzliches GANZZAHL.

=A1+0,9-REST(A1;1)-(GANZZAHL(0,9-REST(A1;1))>0)

Grund: 

0,9-REST(A1;1) ergibt in Excel 1,4432899320127E-15, also nicht exakt 0.

1
Suboptimierer 13.07.2017, 09:52
@Suboptimierer

Man kann auch ein Epsilon einbringen. Das ist hier machbar und sinnvoll, weil die Beträge wahrscheinlich immer auf zwei Stellen gerechnet werden. 

=A5+0,9-REST(A5;1)-(0,9-REST(A5;1)>0,0001)

Danke an Funfroc für den Hinweis.

1
=ABRUNDEN(A1+0,1;0)-0,1

Zellen mit "Zahl" formatieren, 2 Dezimalstellen einstellen

Suboptimierer 13.07.2017, 09:55

Sehr schön! Kurz und knackig.

0
Funfroc 13.07.2017, 09:55

Das ist dann die kurze und elegante Variante... viel zu einfach, als das ich drauf kommen hätte können :-)

0
Suboptimierer 13.07.2017, 14:48
@augsburgchris

Alle bisherigen Lösungen scheitern übrigens bei negativen Beträgen. Da wird immer auf 0,1 gerundet.

0

Wie wäre es mit:

=Abrunden(A1+0,1)-0,1

Was möchtest Du wissen?