Excel-Frage! PLS HELP

...komplette Frage anzeigen

3 Antworten

Es kommt drauf an, ob es sich um UND oder ODER-Verknüpfungen handelt:

UND: =wenn(und(A="hoch";B="gering";C="mittel);1;0)+wenn(und(A="hoch";B="hoch";C="mittel);2;0) + ...

auch
=(A="hoch";B="gering";C="mittel)+(A="hoch";B="hoch";C="mittel)*2 + ...
Da nur eine Bedingung zutreffen kann, wird deren Faktor wiedergegeben.

auch bei ODER brauchst Du keine wenn-Schachtelung, aber man muss die Logik verdammt gut im Kopf haben, wenn man da bei mehreren Argumenten keine Fehler produzieren will (ich schaffs auf Anhieb nur selten!). oder einfacher

=(A="Wort1")+(B="Wort2")+(C=Zahl)
je nachdem, wieviele zutreffen, ist die Summe 1, 2 oder 3

wenn nur 1 Argument zutreffen darf und nicht mehrere
=((A="Wort1!)+(B="Wort2")+(C=Zahl))=1

weitere Kombis sind möglich, aber das würde ausufern.
Ist eine andere Wiedergabe als die einfache Zahl für Wahr (<>0) oder Falsch (=0) erforderlich, kannst Du diese Ausdrücke in eine Wenn-Formel einbetten:
=Wenn(Ausdruck;dann;Sonst)
und mehrere mit + bei Zahlen oder & bei Texten und Mischungen aneinanderhängen.

ich hoffe, ich hab Dich mit dieser umfänglichem AW nicht zu sehr verwirrt!

Iamiam 10.08.2013, 11:50

gleich bei der 2.Formel Fehler, muss heissen:

=(A="hoch")*(B="gering")*(C="mittel)
+(A="hoch")*(B="hoch")*(C="mittel)*2 + ...

(das *1 bei der ersten Gruppe kann man sich sparen, da eine Rechenoperation in Form der Addition folgt)
Da nur eine Bedingungsgruppe zutreffen kann, ...

0

Das erste problem wurde gefixt, nun habe ich jedoch leider erneut eins.

Ich habe eine Zelle welche von mehreren anderen beeinflusst wird. Ich möchte, dass der Ergbenis nur in die eine dafür vorgesehene Zelle kommt.

Erklärung: Zelle - E: Ist die Zelle für das Ergebnis

Zelle:A Zelle:B --> Zelle:E

Wenn nun bestimmte Worte in die Zellen geschrieben werden, wie unten im Bsp. A=Hoch, B= Gering, dann soll dies eine bestimmte Reaktion in Zelle E, wie z.b. die Zahl 1 hervorrufen.

Zelle:A = Hoch Zelle:B = Gering

Wenn ich nun z.b. die Beschriftung tausche, d.h. A=Gering und B=Hoch, dann soll das Ergebnis 2 sein.

Ich habe insgesamt 4 Zeilen-Kombinationen, d.h. es ist nicht so leicht gemacht mit wenn, dann, sonst. Sondern ich muss es irgendwie schaffen, dass ich mehrere wenn, und-Formeln für die eine Zelle schaffe. --> Wenn A=Hoch und B=Gering und C=Mittel ==> Dann 1 Wenn A=Hoch und B= Hoch und C=Mittel ==> Dann 2

ich muss nur insgesamt 4 Fälle machen, wäre ganz cool wenn das klappt. Danke!!

PeterPilz2 10.08.2013, 00:05

brauche also eigentlich nur ne funktionierende "wenn- und Formel" für mehrere "wenn - und's" hintereinander.

0
PeterPilz2 10.08.2013, 00:17

eine gleichung klappt, nur wenn ich eine zweite und dritte hinten ranhängen möchte geht das nicht. So sieht die gleichung für eine tatsache aus:

=WENN(UND(K2="Hoch";K6="Wenig");"3BB")

0
PeterPilz2 10.08.2013, 00:20
@PeterPilz2

=WENN(UND(K2="Hoch";K6="Wenig");"3BB");WENN(UND(K2="Hoch";K6="Hoch");"2BB")

so probiere Ichs

0
Oubyi 10.08.2013, 10:31
@PeterPilz2

Da solltest Du zumindest eine Klammer verschieben, nämlich so:

=WENN(UND(K2="Hoch";K6="Wenig");"3BB";WENN(UND(K2="Hoch";K6="Hoch");"2BB"))

und evtl, auch das FALSCH abfangen, dass Du erhältst, wenn keine der Bedingungen zutrifft, z.B. so:

=WENN(UND(K2="Hoch";K6="Wenig");"3BB";WENN(UND(K2="Hoch";K6="Hoch");"2BB";""))

Klappt es?

0
support6 11.08.2013, 09:47

Liebe/r PeterPilz2,

bitte achte in Zukunft darauf Ergänzungen zu Deiner Antwort über den Link "Antwort kommentieren" in Form eines Kommentars hinzuzufügen. So ist sichergestellt, dass der Zusammenhang im Nachhinein nicht verloren geht, da die Antworten durch die Bewertungen ja ständig in Bewegung sind.

Viele Grüße

Ben vom gutefrage.net-Support

0

Mit einer WENN-Funktion könnte das gehen

PeterPilz2 09.08.2013, 21:32

danke für die schnelle antwort. ja das habe ich mir auch gedacht, jedoch bekomme ich die formel nicht richtig gepacken. eigentlich ist es ja nicht schwer.

Ergebnis Zeile A soll um 10% verringert werden, wenn bestimmtes Wort in Zeile B fällt

0
Oubyi 09.08.2013, 22:59
@PeterPilz2

Ergebnis Zeile A soll um 10% verringert werden, wenn bestimmtes Wort in Zeile B fällt

Meinst Du das so?:

=WENN(B1="Wort";A1*0,9;A1)

1

Was möchtest Du wissen?