Wie kann ich eine Excel Formel mit WENN ODER ODER erstellen?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet
=WENNFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0);WENN(ODER(WOCHENTAG($B3-1)>=6;D3-C3+F3-E3<0);"-";D3-C3+F3-E3))

Funktioniert der SVERWEIS in der bisherigen Form? Ich hab deine Formel einfach in die Wennfehler Prüfung eingesetzt und nicht näher nachgestellt.

Wenn auf das Tabellenblatt Feiertage verwiesen wird wäre es eher sverweis(A3;Feiertage!$A$2:$B$30 etc

Open- und LibreOffice verwenden einen Punkt als Trennzeichen zwischen Tabelle und Bereich (noch so eine Inkompatibilität zu Excel).

2
@Ninombre

anstatt Wochentag verwende ich lieber =Rest(Datum;7)

Wochentage ohne Sa&So ist =Rest(Datum;7)>=2

Wochenende Sa&So ist =Rest(Datum;7)<2

Der Sa ist nämlich 0, der So 1 (zufällig, aber immer, da der 1.1.1900 ein So war (nach xl-Logik*), 1Tag davor,  also der 31.12.1899 ein Sa ist)

Das ist Kontinent-übergreifend einheitlich, im Ggs zu Wochentag, wo die Europäer eine Extrawurst braten (seit vllt 40 Jahren ist da der Mo der 1. Wochentag, nicht mehr der So)

zum *: Da xl (und vllt auch andere vorher) im Jahr 1900 einen Schalttag vermuteten (der fällt bei glatten Hundertern ja aus, ausser bei glatten 400ern), stimmt die Zuordnung vor dem 1.März 1900 nicht. Allenfalls für Astronomen oder Historiker von Bedeutung.

3

Danke, funtkioniert auch fast ;-)


Ich habe die Formel wie folgt umgeschrieben...

=WENN(ISTFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0));WENN(ODER(WOCHENTAG($B3-1)>=6;D3-C3+F3-E3<0);"-";D3-C3+F3-E3))

Das Problem ist, dass es WENNFEHLER nicht im Open Office gibt und ich die Funktion WENN(ISTFEHLER) nutzen muss.

Leider gibt mir die Formel nicht das Ergebniss des SVERWEIS ausgibt.

1

Ich glaub jetzt hab ich es...

WENN Der Tag ein Feiertag ist, erhalt eich den Namen des Feiertages, WENN der Tag ein Sa oder So ist erhalte ich "Wochenende" und WENN die Arbeitszeit geringer als 0 Stunden ist erhalte ich "-", sollte die Arbeitszeit höher als die "Vorlaufzeit" sein, erhalte ich die Zeit...

=WENN(UND(ISTFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0));WOCHENTAG($B3-1)>=6);"Wochenende";WENN(ISTFEHLER(SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0));WENN(D3-C3+F3-E3-(Übersicht.$B$4+Übersicht.$B$5+Übersicht.$B$6)<0;"-";D3-C3+F3-E3-(Übersicht.$B$4+Übersicht.$B$5+Übersicht.$B$6)) ;SVERWEIS(A3;$Feiertage.$A$2:$B$30;2;0)))

Wie finde und markiere ich Dubletten in Open Office Calc?

Wie finde und markiere ich Dubletten in Open Office Calc?

Ich habe eine Calc Datei mit 15 Spalten und mehr als 1000 Zeilen. Irgendwo darin befindet sich eine Dublette. Wie kann ich diese sichtbar machen?

Das sofortige Löschen nutzt mir nichts, da die Datei Ergebnis eines Datenbank Exports ist und ich nach dem Auffinden die Angaben in der Datenbank korrigieren muss.

 

Vielen Dank

...zur Frage

SVERWEIS; WERT AUS ZELLE IM SVERWEIS BENUTZEN

Hallo,

zunächst einmal möchte ich sagen, dass ich hier neu bin und es in keinem Forum eine ähnliche Frage war.

Aus diesem Grund verfasse ich hier mein Anliegen.

Ich arbeite mit dem Programm Microsoft Offe (Excel) 2003.

Ich suche eine Lösung für folgendes:

Ich möchte mit einem SVERWEIS den Wert aus einer Zelle in einer Tabelle auf nem anderen Tabellenblatt suchen.

Nur möchte ich den Wert in der Formel so suchen, dass wenn der Wert in der Zelle geändert wird sich das automatisch auch im sverweis überträgt.

habe z.B. folgendes versucht:

=SVERWEIS(WERT(A25);Tabelle1!$A$2:$B$388;2)

Ich bedanke mich jetzt schon einmal für die Antworten.

Lg

MS

...zur Frage

Excel 2 Formeln verbinden?

Hallo Leute,

ich möchte in Excel in einer Zelle einen Sverweis und eine WENN-Funktion einbauen. Wie kann ich diese miteinander verknüpfen? Wenn(Sverweis...) fällt weg. Kann man die beiden Formeln separat durch ein + verbinden? Sprich erst den Sverweis ud dann + WENN?

lg

...zur Frage

SVERWEIS mit mehreren Suchfunktionen?

Hallo Excel Profis,

ich bin am verzweifeln. Ich habe ein Excel Datei mit zwei Tabellenblättern. Tabellenblatt 1 beinhaltet eine leere Tabelle, welches mit einem SVERWEIS mit Daten aus dem anderen Tabellenblatt ausgefüllt werden soll.

Beispiel:

Wenn man in Zelle C4 z.B. HAM eingibt, soll in Zelle L10 das Gesamtergebnis für diese Typen (HAM und A319) gesucht und angezeigt werden. Also in diesem Falle sollte in der Zelle 12.302 stehen.

Ich habe mehrere Versuche unternommen (SVERWEIS, INDEX, WENN etc.) aber keine Funktion hat bisher geholfen.

Könnt ihr mir hierbei weiterhelfen bitte? Vielen Dank vorab...

...zur Frage

Fortlaufendes Suchkriterium bei SVERWEIS in Excel?

Hallo,

ich habe folgendes Anliegen:

Ich habe eine Excel Tabelle, die sich die Werte aus einer zweiten Arbeitsmappe mithilfe von SVERWEIS bezieht. Das Suchkriterium in der Tabelle sind fortlaufende Zahlen (1001,1002,1003,...) und sind eindeutig in der Wertetabelle vergeben. Wenn ich nun den SVERWEIS in der Tabelle in die gewünschte Zelle schreibe, sieht dieser bspw. so aus: =SVERWEIS("1001";'Preisliste'!$A:$T;Spalte(A1);FALSCH). Der Befehl an sich macht was er soll und funktioniert einwandfrei.

Nun meine Frage: Ist es möglich, dass sich das Suchkriterium beim nach unten ziehen der Zellen immer um +1 verändert und nicht kopiert wird? Ich weiß, ich könnte zwar die Zellenbezeichnung als Suchkriterium vergeben (A1,A2) aber dann wäre keine Sortierung der Tabelle mehr möglich.

...zur Frage

Wie kann ich bei OpenOffice die Datenwerte in 4 Quadranten unterteilen?

Hallo, könnte mir das eventuell jemand erklären wie man die Datenwerte in 4 Quadranten unterteilt bei OpenOffice?

Liebe Grüße :)

...zur Frage

Was möchtest Du wissen?