Excel Formel mit Suchfunktion gesucht?

...komplette Frage anzeigen

2 Antworten

Ich würde andersherum herangehen.

Schaue in der Datei Konto, ob du die dort angegebenen Rechnungsnummern in der Datei findest, in der du die Eingaben tätigst.

Dafür kannst du die Vergleichsfunktion nutzen. Das funktioniert auch arbeitsmappenübergreifend.

Beispiel:

=WENN(ISTZAHL(VERGLEICH(A1;'E:\\\\tmp\\\\[Test1.xlsx]Tabelle1'!A:A;0));"x";"")

Excel arbeitet grundsätzlich so, dass eine Änderung einer Zelle sich auf Formeln auswirken, die diese Zelle verwenden.

Wenn du durch eine Änderung in einer Zelle eine Aktion auslösen willst, kommst du nicht um eine Programmierung herum.

Excel ist quasi so aufgebaut, dass es sich die Daten holt, nicht a"uslöseorientiert".

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
08.12.2015, 12:18

Können die an zwei verschiedenen Rechnern laufen

  Wenn beide Dateien im gleichen Ordner stehen, sucht xl zunächst mal nach der Datei im selben Ordner, unabhängig vom vorhergehenden Verzeichnisbaum.

Könnte sein, dass das nur gilt, wenn du alles mit der Maus zeigst, glaube aber nicht. Vllt weiß da noch i'jemand Genaueres?

0

Du hast zwar sehr viel Information in deine Frage gepackt, aber da durchzublicken wird sehr schwer.

Mit Hilfe der Formel SVERWEIS solltest du etwas auf die Beine stellen können.

Die Dateien müssen dazu nicht geöffnet sein.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?