Excel Formel für abgleich

...komplette Frage anzeigen Beispiel - (Excel, Office, Formel)

2 Antworten

G1: =INDEX(B:B;VERGLEICH(D1*1;A:A;0))

dann runterziehen.

augsburgchris 30.01.2014, 10:54

Sorry hab die Wenn Vergessen:

G2: WENN(E4=INDEX(B:B;VERGLEICH(D2*1;A:A;0));"OK";"nicht OK")

1
whitetiger90 30.01.2014, 11:38
@augsburgchris

Nach einer kleinen korrektur von E4 auf E2 funktioniert das einwandfrei. vielen dank

Ist es möglich das ganze übersichtlicher zu gestalten? Im endefekt brauch ich nur die Zeilen in der "nicht ok" oder "#NV"steht, da ich diese beim lieferanten ändern muss. z.b. das die Zeilen in denen "OK" steht gelöscht wird, aber dann würde die Formel in eine endlosschleife laufen oder?

0
whitetiger90 30.01.2014, 13:24
@augsburgchris

naja das haut nicht ganz so hin. aber das wichtigste hat geklappt. vielen dank für die hilfe

0
augsburgchris 30.01.2014, 14:34
@whitetiger90

nach dem Layout auf deinem mitgeschickten Bild ging ich von Excel 2010 aus und da ist WENNFEHLER bereits implementiert.

oder meinst du so?

G2: =WENNFEHLER(WENN(E2=INDEX(B:B;VERGLEICH(D2*1;A:A;0));"";"nicht OK");"")

in älterer Version dann:

G2: =WENN(ISTFEHLER((WENN(E2=INDEX(B:B;VERGLEICH(D2*1;A:A;0));"";"nicht OK")));"";WENN(E2=INDEX(B:B;VERGLEICH(D2*1;A:A;0));"";"nicht OK"))

0
whitetiger90 31.01.2014, 06:49
@augsburgchris

=WENNFEHLER(WENN(E2=INDEX(B:B;VERGLEICH(D2*1;A:A;0));"";"nicht OK");"")

da war oben ein "nicht OK" zuviel. ist excel 2010 :D danke für die hilfe

1

Danke Jay für deine schnelle Antwort,

habe die Formel von dir ausprobiert. Scheint fast zu funktionieren, hab da wohl noch einen Fehler drin. Weißt du wo der Fehler liegt? (siehe Bild)

Mit formel - (Excel, Office, Formel)
Jay424 30.01.2014, 09:15

Entschuldigung, erst jetzt gelesen.

Eigentlich müsste alles stimmen. Ich vermute es liegt an der Spalte D. Die grüne Ecke signalisiert irgend einen Fehler. Klick mal auf ein Kästchen dieser Spalte, dann sollte eine Fehlermeldung erscheinen. Könntest du die posten?

0
augsburgchris 30.01.2014, 10:40
@Jay424

Die grüne Ecke zeigt an das es hier um Textzahlen handelt. Wird Bereich_Verweis nicht angegeben wird hier auch eine Näherung gesucht und es kommen falsche Werte raus.

0
whitetiger90 30.01.2014, 10:52
@Jay424

also soweit ich das gesehn habe ist das ein fehler in der formel sverweis. habe probiert Bereich_Verweis mit wahr und falsch zu füllen aber funktioniert auch net :D

0
DeeDee07 30.01.2014, 10:53
@Jay424

Zahlen sind in Excel normalerweise rechtsbündig ausgerichtet. Spalte D ist entweder manuell linksbündig ausgerichtet, oder - und das vermute ich - nicht als Standard bzw. Zahl, sondern als Text formatiert. Deshalb klappt der SVERWEIS nicht. Formatier Spalte D als Standard oder Zahl bzw. ins gleiche Format wie Spalte A.

Alternativ zu Jay424s Formel würde ich in G2 schreiben:

=SVERWEiS(D2;$A$2:B$299;2;0)+E2

Falls die Lieferung mit der Bestandsänderung übereinstimmt, ist das Ergebnis 0, ansonsten die Differenz.

0

Was möchtest Du wissen?