Excel Formel für 3 höchsten Werte, jedoch soll jede Zahl nur einmal vorkommen

3 Antworten

OK, ich gehe jetzt davon aus das du in der Spalte C die Ergebnisse haben willst. Dann gebe mal in Zelle C5 folgende Folrmel ein:

=MAX(B5:B16)/3

Jetzt hast du schon mal den höchsten Wert aus deinem Bereich und das auch gleich durch 3 geteilt.

Jetzt in Zelle C6 folgende Formel und auf Zelle C7 runterziehen:

=KGRÖSSTE($B$5:$B$16;ZÄHLENWENN($B$5:$B$16;">="&B5)+1)/3

Jetzt hast du auch den zweit und dritt größten Wert gleich durch 3 geteilt.

Wenn die MAX-Formel in C5 steht, dann klappt die Formel für die nächsten beiden Werte bei mir nicht so, wie von Dir gezeigt, auch das direkte Teilen durch 3 ist für mich ein Problem. Bei mir klappt es SO:
In C5:

=MAX(B5:B16)

(und falls gewünscht in D5: =C5/3)

Dann in C6:

=KGRÖSSTE($B$5:$B$16;ZÄHLENWENN($B$5:$B$16;">="&C5)+1)

und runterkopieren nach C7.
(und falls gewünscht in D6 und D7: =C6/3 und =C7/3)

Jetzt kannst Du für den Durchschnitt der drei größten Werte ohne Doppelte, den Du anscheinend habe willst, entweder:
=MITTELWERT(C5:C7)
oder
=SUMME(C5:C7)/3
oder
=SUMME(D5:D7)
nutzen.

Die KGRÖSSTE-Formel kenne ICH übrigens als ein "Werk" von
Josef Burch
aus dieser Formelsammlung (die man sich übrigens merken sollte):
http://www.excelformeln.de/formeln.html?welcher=68

2
@schmiddi1967

Schreibe mal die größte Zahl NICHT an die erste Stelle (also in B5) und wähle Zahlen, die vom Wert her näher beieinander liegen.
Wie sieht es dann aus?

0
@Oubyi

Ah, bei mir war nur ein kleiner Fehler drin. Beim rüberkopieren hat er Anstatt C5 B5 in die Formel genommen. Sonst geht alles und auch gleich das Teilen durch 3.

Habe ich in deine Formeln auch mal gleich mit rein genommen und geht auch:-))

0
@schmiddi1967

Also das sofortige Teilen durch 3 klappt bei mir nicht und kann meinem Verständnis nach auch nicht klappen, da ZÄHLENWENN sich dann ja auf 1/3 des MAX-Wertes bezieht und somit zuviel Werte zählt. Schau Dir mal meine Screenshot (in neuer Antwort vom mir, da hier nicht möglich) an.
Formel in D5:
=MAX(B5:B16)/3
in D6
=KGRÖSSTE($B$5:$B$16;ZÄHLENWENN($B$5:$B$16;">="&D5)+1)/3
in D7:
=KGRÖSSTE($B$5:$B$16;ZÄHLENWENN($B$5:$B$16;">="&D6)+1)/3

Oder hast Du das anders gemeint?

1
@Oubyi

DH! Oubyi

Ha, du hast vollkommen Recht. Das macht er auch nur beim ersten mal, sobald ich Zahlen ändere bezieht er sich auf die Zelle darüber und nimmt dann einen falschen Wert.

Also do wie du das beschrieben hast, mit der Zelle dahinter zum Teilen. Ich sollte doch lieber erst alles testen bevor ich was Poste.

Danke für deinen Hinweis

0

Eine spezifische Formel kenne ich nicht, aber das ganze lässt sich über mehrere Spalten einfach gestalten.

über der Zelle C5 (Bsp C4) lässt du den höchsten Wert aus B5-B15 eintragen

Darunter machst du eine WENN-Funktion zu jedem Wert von B.

Wenn der Wert von B in dieser Zeile gleich Wie C4 ist, dann soll einfach Null oder leer wiedergegeben werden, und wenn nicht, die Zahl aus der Spalte B.

So eliminierst du alle Zahlen, die gleich dem höchsten Wert sind.

Aus dieser Neuen Zeile machst du das gleich nochmals um die zweithöchste Zahl zu bekommen und um diese dann aus der nächsten Spalte zu entfernen.

Fehlerkorrektur: Aus dieser Neuen Spalte(C5-C15) machst....


Und nachdem zu die Zweitgrösste Zahl hast kannst du dann natürlich nochmals die höchste Zahl daraus wiedergeben. Die WENN-Funktion brauchst du dann aber nicht mehr.

0

Screenshot zu meinem Kommentar:

Screenshot - (Excel, Formel)

Was möchtest Du wissen?