Excel Formel die aus 2 Tabellen die identischen Zahlen in eine dritte Tabelle einfügt, ist sowas möglich?

...komplette Frage anzeigen

4 Antworten

Reicht dir die Abfrage, ob Zahl 1 in Tabelle 1 auch in Tabelle 2 vorhanden ist? So würde ich dich zumindest verstehen.

Dann könntest du recht einfach mit einem s- bzw. wverweis suchen lassen. Wenn man den mit genauer Übereinstimmung suchen lässt, wird bei Nichtvorhandensein ein Fehler ausgegeben. Zahlen ohne Fehler kannst du ja dann kopieren.

Oder gib mal eine Beispieldatei, damit man es genauer versteht.

ich meinte es so, Ergebnisbereich A1-A20, dort sollen alle Zahlen hinein die sich sowohl in Tabelle 1 als auch in Tabelle 2 befinden, also zB eine Formel die ich in Zelle A1 bis A20 einfüge und wenn es in A20 keinen Wert gibt , entweder leer oder 0. Suchbereich zB C1-AP1 und D2-D13

0
@Marceloblau01

In A1 (Tabelle 3):

=WVERWEIS(Tabelle1!D2;Tabelle2!$C$1:$AP$2;1;FALSCH)

und das bis A20 ziehen. Wobei das quatsch ist, wenn du nur D2 bis D13 durchsuchst. Weiterhin gibt es keine Aussage darüber, wie oft die Zahl aus Tabelle 1 in Tabelle 2 vorkommt.

Wenn die Zahl nicht doppelt ist, kommt #NV. Das könnte man noch per istfehler() ausgrenzen, bei Bedarf.

1
@Saloucious

keine Sorge jede Zahl existiert nur einmal, nie doppelt.

ich probiere es gleich mal aus

0
@Marceloblau01

jetzt weiß ich erst was du mit doppelt gemeint hast , wegen dem #NV

istfehler() bitte einbauen danke

0
@Marceloblau01

=WENN(ISTFEHLER(WVERWEIS(Tabelle1!D2;Tabelle2!$C$1:$AP$2;1;FALSCH));0;WVERWEIS(Tabelle1!D2;Tabelle2!$C$1:$AP$2;1;FALSCH))

1

Mit Zählenwenn holst du dir alle Zahlen die Identisch sind.

Liste1: A:A

Liste2: B:B

C1: =Zählenwenn(A:A;B1)

Ergebnis ist hier 0 oder 1 (eventuell mehr bei mehrfachem Vorkommen)

Dann kannst du nach grösser Null Filtern und hast alle identischen Nummern. 

WENN und SVERWEIS (oder sonstiges) sind hier nicht zielführend. 

Spielt die Position der Zahl eine Rolle, oder ist es egal, wo die Zahlen stehen, Hauptsache identisch in beiden Tabellen?

Gruß
Hannes

die Positionen sind eigentlich egal die kann ich dann ja noch ändern oder zuordnen

0

1. Formel: Vergleich in Tabelle 2
                  Wenn Wert Tabelle1=Tabelle2, dann =1 sonst =0

2.Formel in 3. Tabelle
                   Wenn Wert =1, dann übertrage Zahl, sonst " "

So müsstest du ran gehen und zur Lösung kommen.

so ungefähr hab ich es auch angehen wollen, aber ich habe was Formeln schreiben angeht nur geringes Wissen also wenn du das vielleicht bitte in eine fertige Formel packen könntest wäre das sehr lieb von dir und ich könnte es ausprobieren ob es geht!

0
@Marceloblau01

Sind einfach Wenn-Abfragen und ein Profi würde sicher eine bessere Lösung finden.

Bevor ich die Formel schreibe, noch eine kurze Frage: Soll in den Tabellen jeweils immer der 1. Wert miteinander verglichen werden? Also A1 mit A1, B1 mit A2, C1 mit A3 usw. ? 

1
@TestBunny

WENN ist hier definitiv der falsche Ansatz weil die Fragestellung damit gar nicht zu beantworten ist.

1
@augsburgchris

Ich habe mir 2 Tabellen, wie hier gemacht und dann entsprechend eine 3. Tabelle mit den Übereinstimmungen. Es hat durchaus funktioniert.

0
@TestBunny

Dazu muss aber der gleiche Wert auch immer in der gleichen Zeile stehe. Das ist bei der Fragestellung jedoch nicht der Fall. Wenn die 4 einmal in Zeile 18 und einmal in Zeile 100 steht funktioniert es nicht außer du baust ein Array um deine Wennformel.

0

Was möchtest Du wissen?