Excel Experten gesucht !!! Warum summiert Excel nicht? ?

... komplette Frage anzeigen

4 Antworten

Sobald du in einer Formel Werte mit & verkettest, wird der Inhalt als Text formatiert (ein Schnell-Indiz ist die Linksbündigkeit). Texte werden bei der Berechnung als 0 gewertet.

Wenn ich das richtig sehe, willst du in A4 "A" stehen haben, wenn es in Zeile 1 gefunden wird. In den nächsten willst du die Zahl an 1. (2. und 3.) Stelle rechts vom gefundenen A ausgeben. Dazu würde ich in A4 folgende Formel verwenden:

=WENN(ISTFEHLER(INDEX(1:1;1;VERGLEICH("A";1:1;0));"";"A")

In B4 dann:

=WENN($A4="";"";INDEX(1:1;1;VERGLEICH("A";1:1;0)+SPALTE(A1)))

Diese Formel sucht in der 1. Zeile nach "A" und gibt den Wert rechts daneben aus.

Diese Formel kannst du nach rechts bis D4 kopieren, dann wird in C4 der 2. Wert neben dem gefundenen A in Zeile 1, in D4 der 3. Wert ausgegeben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von decentr
27.07.2016, 21:38

A , 1, 2, 3 tippe ich selber.. Wenn ich So tippe, unten von B4 wir A erkannt, somit fangt zum summieren an Also hier =6 Angenommen A1= A B1= 3,00 C1= 30,00 D1=300,00 D4 soll summe 333,00

0
Kommentar von decentr
27.07.2016, 23:14

woher bist du?

0

Ich würde die Formel etwas umschreiben und die Funktion "WENNS" nutzen. Hiermit hast du alle Bedingungen zusammen in einer Formel.

https://support.office.com/de-de/article/WENNS-Funktion-36329a26-37b2-467c-972b-4a39bd951d45

Oder "SUMMEWENNS":

https://support.office.com/de-de/article/SUMMEWENNS-Funktion-c9e748f5-7ea7-455d-9406-611cebce642b


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von decentr
27.07.2016, 20:58

excel 2016? Gibt es diese Wenns auch bei 2007?

0
Kommentar von decentr
27.07.2016, 21:22

Flasch8acks, Oberen Formel ist 100% Funktionfähig; ich will nicht alles summieren, Wenn in A1; A steht sol 1 2 3 nehmen summe= 6 das wars

1
Kommentar von decentr
27.07.2016, 21:44

Ich versuch mal

0

Wo mache ich Fehler?

Durch & wird kein "Wert" erzeugt.

Sollte aber so lösbar sein:

=Summe(B4+C4+D4)

oder

=B4+C4+D4

Antwort bewerten Vielen Dank für Deine Bewertung

In deiner oben genannten Formel ist ist keine Aufforderung zum Summieren enthalten (kein "+" und kein "Summe"), deshalb summiert EXCEL hier nicht, sondern liefert nur Textwerte.


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von decentr
27.07.2016, 23:13

genannte Formel ist ein Beispiel Formel von einer Zelle, im angähengter Datei sind 14 Formeln drin..

0

Was möchtest Du wissen?