Excel ersten 5 Spalten automatisch löschen?

...komplette Frage anzeigen So habe ich die Tabelle - (Computer, Excel) So muss die Tabelle dann aussehen - (Computer, Excel)

2 Antworten

Mein makrofreier Ansatz wäre dieser:

Wenn die Namen in Spalte A stehen

=WENN(ZÄHLENWENN(A$1:A$10000;A1)-5<ZÄHLENWENN(A1:A$10000;A1);"X";"")

wichtig sind die $ Zeichen! A$1:A$10000 ermittelt die Gesamtanzahl eines Namens, A1:A$10000 (da erhöht sich A1 zu A2, A3... mit steigender Zeilenzahl) die wievielte Wiederholung es ist (in umgekehrte Reihenfolge quasi)

Gibt es 8 Peter sind die ersten 5 Nennungen mit X zu löschen.

Formel für alle Einträge runterziehen / kopieren. Dann die Spalte mit der Formel kopieren > irgendwo als Werte einfügen, damit sich nichts mehr verändert und danach mit dem Autofilter die X filtern und löschen.

Oubyi 06.10.2016, 12:26

DH!
Ginge aber wohl auch etwas knapper:
Formel in z.B C2 (in C1 steht manuelle eingetragen ein X):

=WENN(ZÄHLENWENN($B$1:B2;B2)<=5;"X";"")

und runterkopieren.
Es sollte allerdings sichergestellt sein, dass keine Namen weniger als 6 mal vorkommen, sonst würde der Name komplett aus der Liste entfernt. Falls das nicht so ist, ist das hier die "sichere Seite":

=WENN(UND(ZÄHLENWENN(B2:$B$100000;B2)>1;ZÄHLENWENN($B$1:B2;B2)<=5);"X";"")

1
Ninombre 06.10.2016, 12:29
@Oubyi

heute ist ein Tag zum kompliziert denken, wie es scheint

1
Oubyi 06.10.2016, 12:34
@Ninombre

DAS passiert mir fast jeden Tag. 

0

Mach in Spalte C (oder einer beliebigen anderen) einen  Zähler.

C1: =1
C2: =WENN(B2=B1;C1+1;1)

C2 herunterziehen.

Es geht noch weiter...

Suboptimierer 06.10.2016, 10:58
D1: =ZÄHLENWENN(B:B;B1)-5>=C1

D1 herunterziehen.

Dann legst du einen Autofilter auf die Tabelle und filterst in Spalte D auf WAHR.

1

Was möchtest Du wissen?