Excel: Erstellen einer Zahlenreihen mit Formel?

... komplette Frage anzeigen

4 Antworten

Es soll aber ohne Runterziehen gemacht werden. Wenn ich z.b. den Wert 10
habe, dann soll automatisch die Reihe bei 10 aufhören. wenn ich den
wert 5 habe, soll die Reihe nur bis 5 gehen.

Schreibe den Endwert in A1, z.B. 10.
Dann diese Formel in A2 und runterkopieren, bis zur maximal in A1 einzugebenden Zahl:
=WENN((ZEILE()-1)<=$A$1;ZEILE()-1;"")
Du kommst nicht darum herum in den Bereich unter A1 Formeln einzugeben (es sei denn Du möchtest VAB-Code nutzen, dann frag nochmal nach), aber mit dieser Formel werden nur die z.B. ersten 10 Zellen hochgezählt, die restlichen Formel-Zellen bleiben leer.
Hilft Dir das weiter?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von romeboising
06.02.2016, 20:42

Super danke. Das war genau das was ich suchte.

0

Um das "runterziehen" kommst Du mit Formeln nicht wirklich herum. Nur wo eine Formel steht, kann die Zelle auch einen Wert annehmen, abhängig von irgendwelchen Bedingungen. Alles andere bedarf VBA/Makro.

Ansatz vielleicht:
A1 = Die Maximale Zahl

A2= =WENN(ZEILE(A2)<=A$1;ZEILE(A2)-1;"")

runter kopieren, bis zur maximal erwarteten Zahl.

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo, danke für die schnelle Antwort. 

Es soll aber ohne Runterziehen gemacht werden. Wenn ich z.b. den Wert 10 habe, dann soll automatisch die Reihe bei 10 aufhören. wenn ich den wert 5 habe, soll die Reihe nur bis 5 gehen.

Antwort bewerten Vielen Dank für Deine Bewertung

In a1 den Startwert eingeben und dann in b1: =a1+1 und die Formel nach unten kopieren

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von vitus64
06.02.2016, 19:09

Ich meinte natürlich: in a2 die genannte Formel eingeben und nach unten kopieren

1

Was möchtest Du wissen?