Excel DropDown-Liste mit Feld verknüpfen?

... komplette Frage anzeigen

2 Antworten

=Vergleich(gewählterWert aus DropdownListe;DropdownBasisliste;0) gibt die ListenPosition(snummer des gewählten Eintrags wieder.

Bei mehreren/vielen  durch Dropdown abgerufenen Zellen die Formel kopieren mit variablem Bezug auf das Wiedergabefeld und $-Setzung der Dropdownbasisliste.-

(Bei Verweis müsste die erste Liste erstens steigend geordnet sein und zweitens die {zweite}bei jeder Änderung nei geschrieben werden)


Antwort bewerten Vielen Dank für Deine Bewertung

Ist Dropdown für Dich Datengültigkeit prüfen > Liste? Sind die auswählbaren Elemente in einem Tabellenblatt aufgelistet? Dann würde es in etwa so gehen:

Wenn bspw. die Auswahl des Dropdown in Zelle C1 steht:
=SUMMENPRODUKT((Tabelle!A1:A100=C1)*ZEILE(1:100))

Wenn die Auswahl in der Datengültigkeit selbst hinterlegt ist, müsstest Du es in der Formel nochmals eintragen:

=VERWEIS(C1;{"Müller";"Meier";"Schmidt"};{1;2;3})

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?