Excel 'Division durch Null' - Fehler. Wie bekomme ich die Zelle leer beziehungsweise 0,00mm²?

... komplette Frage anzeigen

3 Antworten

Wennfehler wäre hier eine unsaubere Programmierung - da sämtliche Fehler in den Eingaben zum einem verwertbaren Ergebnis führen.
Sinnvoller erscheint mir
um die Formel ein Wenn abfrage ob die Zelle leer sind

Da deine Formel leider verhunzt ist (durch die Autoformatierung hier) kann ich die endversion leider nicht anbieten.
im Grunde etwa so

=WENN(ODER(B9="";B10="");0;deine Formel)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von maxi1701
26.08.2015, 10:28

Peferkt, so hats funktioniert!

Vielen Dank!

0

Würde sagen du musst die mögliche Division durch 0 abfangen - also das wo 0 rauskommen könnte in die WENN-Klammer setzen. Dass Excel da einen Fehler bringt ist richtig. Achte vielleicht auch auf die Nachkommastellen, welche Excel zur Berechnung heranzieht. Möglicherweise werden zu wenige genommen um die Division durch 0 verhindern zu können

Antwort bewerten Vielen Dank für Deine Bewertung

Hi Maxi, 

=WENN(ODER(ISTLEER(B9);ISTLEER(B10));0;
(B6*B7)-(4-PI())*(B8^2) 
-((2*(B9*(B9*(2*ARCCOS(1-B11/B9)))/2-(2*WURZEL(2*B9*B11-B11^2))*(B9-B11)/2))
+(2*(B10*(B10*(2*ARCCOS(1-B11/B10)))/2-(2*WURZEL(2*B10*B11-B11^2))*(B10-B11)/2))) )

nicht viel anders als "Jackie", aber so würde ich es lösen. Zusätzlich habe ich noch eine "Klammer auf-zu" zuviel im zweiten Term gefunden und gleich eliminiert.

Distel

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?