Excel: Die Werte in A1 und B1 sollen addiert werden und das Ergebins soll unter bestimmten Bedingungen in C1 angezeigt werden. Wie ist die Formel?

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Hallo,

folgende Formel würde genügen.

=WENN(ODER(A1="";B1="");"";Auswerteformel)

Auswerteformel bedeutet, dass eine Bezugsberechnung stattfindet, wenn in A1 oder B1 ein Wert eingegeben ist/wird.

Gruß Tron

in A1 UND B1 muss ein wert stehen, heißt, WEDER A1 NOCH B1 darf leer sein!

Also: ODER(NICHT(ISTLEER(A1));Nicht(istleer(B1)))

eingebaut:

=Wenn(ODER(.....);Auswerteformel für A1 und B1;"")

Istleer bezieht auch Formeln mit ein, die leer darstellen, im einfachsaten Fall =""

Ist damit nicht zu rechnen, bzw soll sowas einfach ignoriert werden, gehts kürzer so:

=Wenn((A1="")+(B1="");Auswerteformel;"")

(+ kann anstatt ODER() für Logik-Verknüpfungen verwendet werden, weil jede Zahl <>0 als WAHR gelesen wird. Sind also beide Zellen gefüllt, resultiert 2, was <>0 ist.

UND wäre (A1="")*(B1="") [ist ein Faktor 0, wird das Produkt 0]

zu kompliziert? dann lies nur die ersten 5 Zeilen, das würde genügen. Die aber musst Du verstanden haben!

jetzt hab ich mich selber wieder mal in den Fallstricken der Logik verheddert, man muss sich da aufs Äusserste konzentrieren!:

zweite Zeile muss lauten:  UND(Nicht(istleer(A1));Nicht8Istleer(B1))) (nur dann soll ja gerechnet werden)

Geht auch andersrum:

=Wenn(ODER(istleer(A1);istleer(B1)),"";Auswerteformel)   ist kürzer

0

In der ausführlichen Form brauchst du die Funktionen WENN, ODER und ISTLEER.

In Worten: Wenn das eine leer ist oder das andere leer ist, dann leer, sonst addieren.
___________

Du kannst auch andersherum arbeiten.

Wenn das eine nicht leer ist und das andere nicht leer ist, dann addieren, sonst leer.

Hierfür brauchst du WENN, UND, NICHT und ISTLEER.

Danke, könntest Du mir die Formel aufschreiben? Danke

0
@Weissgarsnix

Hmm, hast du das denn wenigstens schon probiert? -.- Es sollte mit der Hilfestellung nicht mehr die Kunst sein.

=WENN(ODER(ISTLEER(A1);ISTLEER(B1));"";A1+B1)

Wenn du beim Aufbau dieser Formel trotz Hilfestellung Probleme hattest, empfehle ich dir, weitere Übungen zu bearbeiten, damit du bei einem Test nicht auf die Nase fällst.

2
@Suboptimierer

jetzt hab ich die Frage anscheinend schon fast den halben Tag offen und dazwischen was anderes gemacht, na ja, jetzt ist es halt doppelt gemoppelt!

0

Was möchtest Du wissen?