Excel: Datum als Text ausgeben

...komplette Frage anzeigen

1 Antwort

B1: =WENN(A1<>"";"[Strg]+.";"")
Suboptimierer 26.03.2015, 17:02

Wenn du das so meinst, dass sobald sich in A1:A1000 etwas ändert, in Abhängigkeit von A1:A1000 in B1:B1000 das aktuelle Datum eingetragen werden soll, hilft ein Makro:

Private Sub Worksheet_Change(ByVal Target As Range)
  If Not Intersect(Range("A1:A1000"), Target)
 Is Nothing Then
    If Target.Value <> "" And Target.Count = 1 Then
      Target.Offset(0, 1).Value = Date
    End If
  End If
End Sub

Diese Variante benötigst du, wenn du einen speziellen Auslöser brauchst (hier Änderung einer Zelle), der bewirkt, dass das aktuelle Datum in eine Zelle geschrieben wird.

0
Suboptimierer 26.03.2015, 17:09
@Suboptimierer

Den Count musst du noch als extra IF aus der Bedingung herausziehen, da schon die .Value <> "" Prüfung fehl schlägt, wenn Count > 1 ist.

0
Iamiam 27.03.2015, 12:04
@Suboptimierer

wieder was gelernt! habe geglaubt, dass

Target.Count = 1 als Target.Cells().Count = 1

zu formulieren sei!

0

Was möchtest Du wissen?